Bug 22286 - Problem with printing software
Summary: Problem with printing software
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-14 06:53 UTC by Joachim Backes
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 06:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2000-12-14 06:53:12 UTC
Printing with RedHat 7.0 fails if the printer is
connected to some network connected BSD system
(I didn't try printing for directly connected
printers):

The problem is the following: I inspectected 
/var/spool/lpd/myprinter (for ex.) and found out that
the filter script "filter" is a link to 

	/usr/lib/rhs/rhs-printfilters//master-filter

Workaround:

When deleting the link "filter" and exchanging it by a
direct copy of /usr/lib/rhs/rhs-printfilters//master-filter
and calling "chmod o+x filter", the problem is away.

Known?

Joachim Backes

--

Joachim Backes <backes@rhrk.uni-kl.de>       | Univ. of Kaiserslautern
Computer Center, Supercomputing Division     | Phone: +49-631-205-2438 
D-67653 Kaiserslautern, PO Box 3049, Germany | Fax:   +49-631-205-3056 
---------------------------------------------+------------------------
WWW: http://hlrwm.rhrk.uni-kl.de/home/staff/backes.html

Comment 1 Crutcher Dunnavant 2001-02-02 01:04:56 UTC
I have no idea why that would fix it.
Could you return the result of and past it into the bug report?:

ls -l /usr/lib/rhs/rhs-printfilters/master-filter

Comment 2 Joachim Backes 2001-02-02 06:58:31 UTC
The problem disappeared after a complete new installation
of RH 7.0 (Previously, my RH 7.0 was an update made over RH 6.2).

Comment 3 Joachim Backes 2001-03-14 05:56:28 UTC
After removing the rpms
	
	printtool-3.54-1.noarch.rpm
	rhs-printfilters-1.81-1.i386.rpm
	LPRng-3.6.22-5.i386.rpm

and reinstalling printtool and rhs-printfilters from the RH Disk1
and installing LPRng-3.7.4-1.i386.rpm, the problem disappeared.


Note You need to log in before you can comment on or make changes to this bug.