Bug 222875 - Kernel panic - not syncing: SM: Record message above and reboot.
Kernel panic - not syncing: SM: Record message above and reboot.
Status: CLOSED CANTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 12:58 EST by Tomasz Jaszowski
Modified: 2009-04-16 16:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 09:04:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic on iLO (147.21 KB, image/jpeg)
2007-01-16 12:58 EST, Tomasz Jaszowski
no flags Details

  None (edit)
Description Tomasz Jaszowski 2007-01-16 12:58:39 EST
Description of problem:
We have cluster with two node with shared storage (GFS).
During test of gfs (creating/mounting/umounting/recreating) after or during
reboot we had 'kernel panic'. Node fencing was disabled by invalid password set.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux ES release 4 (Nahant Update 4)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
on iLO we have notticed:

CMAN: removing node tefse-pro1 from the cluster : Missed too many heartbeats


SM: Assertion failed on line 52 of file
/usr/src/redhat/BUILD/cman-kernel-2.6.9-45/smp/src/sm_misc.c
SM: assertion: "!error"
SM time = 230783
error = -1, nodeid = 4294967295

Kernel panic - not syncing: SM: Record message above and reboot.

Expected results:
Why this node got 'kernel panic' ?

Additional info:
unfortunately i don't have any time stamp, and I can't find any logs regarding
this kernel panic at /var/log/messages.
Comment 1 Tomasz Jaszowski 2007-01-16 12:58:39 EST
Created attachment 145711 [details]
kernel panic on iLO
Comment 2 Christine Caulfield 2007-01-17 06:19:58 EST
It seems to be requesting node id -1 from cman (which is invalid).

Dave: did cman give SM this node number ?
Comment 3 Tomasz Jaszowski 2007-01-22 07:16:06 EST
Hi,

 Any ideas how to avoid this kernel panic? (we would like to join this system
into production, so answer to this bug becoming critical...)

Thanks

Comment 4 David Teigland 2007-01-22 10:01:37 EST
Could you describe exactly what you did to get this?  And does it happen
every time you do that?
Comment 5 Tomasz Jaszowski 2007-01-24 03:08:02 EST
it happened during configuration of GFS partitions. We created them, added to
fstab, mounted, unmounted few times, few times rebooted...and after one of those
reboots on one of nodes we saw that message. Unfortunately I can't provide exact
path how to reproduce it. 

We didn't tried to reproduce it, and it happened only once
Comment 6 Tomasz Jaszowski 2007-01-25 16:20:44 EST
(In reply to comment #5)
> it happened during configuration of GFS partitions. We created them, added to
> fstab, mounted, unmounted few times, few times rebooted...and after one of those
> reboots on one of nodes we saw that message. Unfortunately I can't provide exact
> path how to reproduce it. 
> 
> We didn't tried to reproduce it, and it happened only once

nothing more to add
Comment 7 Tomasz Jaszowski 2007-02-02 10:38:04 EST
Hi

any ideas?
Comment 8 Christine Caulfield 2007-02-02 12:19:39 EST
Not without any more information, no. Sorry.
Comment 9 Tomasz Jaszowski 2008-01-08 09:04:29 EST
as I'm not able to provide more detailed informations, setting as cantfix. 

Thanks for help

Note You need to log in before you can comment on or make changes to this bug.