Bug 22290 - rpm is case sensitive
rpm is case sensitive
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-14 06:17 EST by Nicolas CROISET
Modified: 2009-09-08 10:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-14 06:17:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas CROISET 2000-12-14 06:17:27 EST
Hello,

For example if I install MySQL.3.22.32-1.i386.rpm (find on mysql.com) instead of mysql-3.23.24-1.i386.rpm...
Then if I want to install something else where there is dependencies with this package, or if I want to rebuild php-4.0.3pl1-4.src.rpm (with the 
option --rebuild), it's impossible to do this because the dependencies fail (so I must use the option --nodeps to rebuild and install).

So is it possible to find a solution for this problem.

Thanks.
Comment 1 Jeff Johnson 2000-12-16 20:09:11 EST
rpm, like most unix utilities, is case sensitive, so MySQL and mysql are names
of different
packages even though they may have the same contents.
Comment 2 Nicolas CROISET 2000-12-17 08:54:48 EST
So is it possible to redhat to respect the case of the original package of mysql, and put in redhat MySQL package not mysql, and the problem is solve.

Bye

Note You need to log in before you can comment on or make changes to this bug.