Bug 222936 - openpbx 1.2-rc3 released
Summary: openpbx 1.2-rc3 released
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openpbx (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-16 22:10 UTC by Kevin Fenzi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 03:05:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file for rc3 (2.44 KB, patch)
2007-02-06 18:19 UTC, Kevin Fenzi
no flags Details | Diff

Description Kevin Fenzi 2007-01-16 22:10:00 UTC
Description of problem:

openpbx is version 1.2-3.rc2.svn2135 in fedora extras. 

Should upgrade to 1.2-rc3 now that it's available.

Comment 1 David Woodhouse 2007-01-16 23:37:17 UTC
I am away from home until the end of the month and cannot do any prerelease
testing. If you want to update it in my absence please go ahead. spandsp and
mISDN may want updating.

Comment 2 Kevin Fenzi 2007-01-17 02:21:47 UTC
I can at least try and do some testing with the new version. 

I'm hoping it fixes a problem I am seeing here where incoming zap channel calls 
get no caller id. ;( 

Will update this bug with results after I have done some testing on it. 

Comment 3 Kevin Fenzi 2007-02-06 18:17:57 UTC
I have tried to get a 1.2-rc3 package to work, but it runs into a weird
libreadline issue. 

The build ends with:

gcc -Wl,--as-needed -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -o .libs/openpbx openpbx-main.o 
./corelib/.libs/libopenpbx.so -lspandsp -ltiff -L/usr/lib -lssl -lcrypto
-lsqlite3
/builddir/build/BUILD/openpbx.org-1.2_rc3/corelib/jitterbuffer/.libs/libopbxjb.so
./libltdl/.libs/libltdlc.a -ldl -lreadline -llber -lldap -lrt -lresolv -lpthread
-lnsl -lncurses -lm -lc -Wl,--rpath -Wl,/usr/lib/openpbx.org
/usr/lib/libreadline.so: undefined reference to `PC'
/usr/lib/libreadline.so: undefined reference to `tgetflag'
/usr/lib/libreadline.so: undefined reference to `tgetent'
/usr/lib/libreadline.so: undefined reference to `UP'
/usr/lib/libreadline.so: undefined reference to `tputs'
/usr/lib/libreadline.so: undefined reference to `tgoto'
/usr/lib/libreadline.so: undefined reference to `tgetnum'
/usr/lib/libreadline.so: undefined reference to `BC'
/usr/lib/libreadline.so: undefined reference to `tgetstr'
collect2: ld returned 1 exit status

Any ideas?

I will attach a diff of the changes I have now. 

Two items: 

- The version is not up to guidelines... the 1.2 final is going to have be -5, I
changed it to match the guidelines, so at least additional rc's won't cause issues. 

- The lack of sqlite causes anoying messages in my openbpx messages log: 
Feb  6 04:29:09 WARNING[1151847312] db.c: SQL ERR [unable to open database file]
Can it be re-enabled now?



Comment 4 Kevin Fenzi 2007-02-06 18:19:46 UTC
Created attachment 147497 [details]
patch to spec file for rc3

This is what I was testing with so far.

Comment 5 Kevin Fenzi 2007-05-30 04:09:35 UTC
Looks like openpbx changed it's name to "callweaver"... 

http://callweaver.org/blog/3

Perhaps update to the current svn and do the rename? 
Let me know if you would like me to assist any.

Comment 6 Kevin Fenzi 2007-07-04 03:05:23 UTC
This bug is largely moot now, since openpbx changed its name to callweaver and
is newer than the requested openpbx version. Closing. 


Note You need to log in before you can comment on or make changes to this bug.