Bug 222946 - Update request: flac 1.1.3
Update request: flac 1.1.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flac (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
http://flac.sourceforge.net/news.html...
:
Depends On:
Blocks: FC7Target FC7UpdateRequests
  Show dependency treegraph
 
Reported: 2007-01-16 17:49 EST by Michel Alexandre Salim
Modified: 2009-09-21 15:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 04:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mandriva patch for vorbis-tools for flac 1.1.3 support (18.12 KB, patch)
2007-02-01 22:04 EST, Matthias Clasen
no flags Details | Diff
patch for gstreamer-plugins-good (35.59 KB, patch)
2007-02-01 23:58 EST, Matthias Clasen
no flags Details | Diff
flac-1.1.3-gnu-stack.patch (1016 bytes, patch)
2007-02-01 23:59 EST, Matthias Clasen
no flags Details | Diff
flac-1.1.3-noxmms.patch (1.31 KB, patch)
2007-02-02 00:01 EST, Matthias Clasen
no flags Details | Diff
flac-1.1.3-link-ogg.patch (559 bytes, patch)
2007-02-02 00:01 EST, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2007-01-16 17:49:06 EST
Description of problem:
Both FC-6 and Rawhide still has flac 1.1.2. The latest version, 1.1.3, provides
among other things higher compression ratio and error recovery. Could this be
pushed at least into Rawhide?


Version-Release number of selected component (if applicable):
1.1.2-27
Comment 1 Matthias Clasen 2007-02-01 21:40:45 EST
I looked a bit into this, and found that flac is required by vorbis-tools and
gstreamer-plugins-good. And both don't work with flac 1.1.3, since it changed API
again. So this will have to wait until dependencies are updated to work with
flac 1.1.3
Comment 2 Matthias Clasen 2007-02-01 21:50:22 EST
patch for gstreamer-plugins-good is in
http://bugzilla.gnome.org/show_bug.cgi?id=385887
Comment 3 Matthias Clasen 2007-02-01 22:04:28 EST
Created attachment 147178 [details]
mandriva patch for vorbis-tools for flac 1.1.3 support
Comment 4 Matthias Clasen 2007-02-01 23:58:25 EST
Created attachment 147186 [details]
patch for gstreamer-plugins-good
Comment 5 Matthias Clasen 2007-02-01 23:59:59 EST
Created attachment 147187 [details]
flac-1.1.3-gnu-stack.patch
Comment 6 Matthias Clasen 2007-02-02 00:01:04 EST
Created attachment 147188 [details]
flac-1.1.3-noxmms.patch
Comment 7 Matthias Clasen 2007-02-02 00:01:58 EST
Created attachment 147189 [details]
flac-1.1.3-link-ogg.patch
Comment 8 Matthias Clasen 2007-02-02 00:06:29 EST
I found that I needed to update some of the flac patches, and also had to make
sure that libFLAC.so is linked against libogg.so, otherwise the gst-plugins-good
configure test will fail.

Since this affects a good chunk of extras packages:
akode
audacious-plugins
audacity
easytag
flac123
gstreamer08-plugins
gstreamer-plugins-good
k3b
kdemultimedia
kid3
libtunepimp
mkvtoolnix
muine
scummvm
stratagus
xine-lib
xmms-flac

it would probably be a good idea to give a heads-up on fedora-maintainers
first.
Comment 9 Michel Alexandre Salim 2007-02-03 20:36:14 EST
Heads-up sent to the list. Could you perhaps host test 1.1.3 RPMs somewhere?
Makes it easier for package maintainers to verify their packages work.
Comment 10 Matthias Clasen 2007-02-05 11:20:00 EST
Packages are at http://people.redhat.com/mclasen/flac/
Comment 11 Matthias Clasen 2007-02-05 14:08:34 EST
I've put the flac.spec there too, now.
Comment 12 Bastien Nocera 2007-02-13 04:07:15 EST
Here goes.

* Tue Feb 13 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.3-1
- Update with work from Matthias Clasen <mclasen@redhat.com> up
  to upstream 1.1.3 (#229462)
- Remove xmmx-flac Obsolete, as we don't ship the xmms plugin
Comment 13 Miroslav Lichvar 2007-02-14 03:45:47 EST
flac-1.1.4 was released, there are no API changes, should be pretty easy to update.
Comment 14 Bastien Nocera 2007-02-14 06:58:47 EST
1.1.4 is building now.
Comment 15 Gérard Milmeister 2007-02-15 18:47:27 EST
graveman seems to compile against the new version, however I did not succeed
with audacity. So I will build it without flac for now.

Note You need to log in before you can comment on or make changes to this bug.