Bug 222949 - Wireless NIC is named __tmp????????? after boot instead of eth1
Wireless NIC is named __tmp????????? after boot instead of eth1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 18:01 EST by Marcelo
Modified: 2014-03-16 23:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 12:46:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg script for eth1 (146 bytes, text/plain)
2007-01-17 17:50 EST, Marcelo
no flags Details
ifcfg script for eth1 (146 bytes, text/plain)
2007-01-17 17:50 EST, Marcelo
no flags Details
ifcfg script for eth0 (199 bytes, text/plain)
2007-01-17 17:51 EST, Marcelo
no flags Details

  None (edit)
Description Marcelo 2007-01-16 18:01:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Sometimes, after booting the computer, my wireless NIC is named __tmp????????? (the question marks are random digits). I was not able to identify a pattern in this behavior. In every boot, the wireless NIC may be named eth1 or __tmp?????????, with no apparent reason.
If it is not shown as eth1, I need to reboot and try again, until it's correctly shown as eth1. Right before filling this bug, I've rebooted the machine six times in a row until I got the NIC named eth1.
When the NIC is shown as __tmp?????????, KNetworkManager sees all available networks, but can't connect to any of them because dhcpcd is not able to get the IP configuration. If I rmmod ipw2200 and restart NetworkManager, the wireless NIC is correctly named eth1, but then KNetworkManager does not see the wireless networks. I can use the NIC only if it's shown as eth1 after booting.


Version-Release number of selected component (if applicable):
initscripts-8.45.7-1

How reproducible:
Sometimes


Steps to Reproduce:
1. Boot the computer
2. See if the wireless NIC was correctly named eth1. If not, go to step 1.
3. Connect to your wireless network.

Actual Results:
After each boot, the wireless NIC may or may not be named eth1. If it's shown as __tmp?????????, another reboot is needed, until it's shown as eth1.

Expected Results:
The wirless NIC should never be named __tmp?????????.
It should be named eth1 after every boot.

Additional info:
This computer is a centrino notebook with a intel ipw2200 wireless NIC.
The kernel I'm running is: kernel-2.6.18-1.2849.fc6
NetworkManager version is: NetworkManager-0.6.4-5.fc6
Normally, I have the network daemon ON with no NICs up on start up, NetworkManager ON and NetworkManagerDispatcher ON. I've tried to chkconfig network off, with no positive results.
Comment 1 Bill Nottingham 2007-01-17 10:29:50 EST
Please attach your /etc/sysconfig/network-scripts/ifcfg-* files.
Comment 2 Marcelo 2007-01-17 17:50:07 EST
Created attachment 145868 [details]
ifcfg script for eth1

As requested, the ifcfg script for eth1
Comment 3 Marcelo 2007-01-17 17:50:26 EST
Created attachment 145869 [details]
ifcfg script for eth1

As requested, the ifcfg script for eth1
Comment 4 Marcelo 2007-01-17 17:51:36 EST
Created attachment 145870 [details]
ifcfg script for eth0

As requested, the ifcfg script for eth0
Comment 5 Bill Nottingham 2007-01-18 12:46:00 EST
Add a HWADDR=<whatever the mac address is for your wireless card> in ifcfg-eth1;
the problem should go away.

Closing as WORKSFORME, as it's essentially a configuration issue; unfortunately,
the code that writes the configs wasn't fixed until after release.

Note You need to log in before you can comment on or make changes to this bug.