Bug 222958 - Linux install screen for RHEL4 will display shifted on flat panel monitors
Linux install screen for RHEL4 will display shifted on flat panel monitors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11-drv-vga (Show other bugs)
4.4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
desktop-bugs@redhat.com
:
Depends On:
Blocks: RHEL4u7_relnotes RHEL4u8_relnotes
  Show dependency treegraph
 
Reported: 2007-01-16 22:12 EST by LisaWu
Modified: 2010-08-25 19:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 19:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shifted image during RHEL4 installation (28.69 KB, image/pjpeg)
2007-01-16 22:12 EST, LisaWu
no flags Details

  None (edit)
Description LisaWu 2007-01-16 22:12:13 EST
Description of problem:
When install RHEL4(any update level) on a ATI ES1000 system,image shifts to 
right and down. The shift can obscure some of the options at the bottom of the 
screen.  
This problem has been seen when using certain flat panel monitors and with 
remote-KVM systems which use analog video input.  The problem is also present 
with DVI video but is more pronounced from analog sources.

Version-Release number of selected component (if applicable):

RHEL4 installation kernel 

How reproducible:
always

Steps to Reproduce:
1.boot from the RHEL4 Linux install CD (any update level)
2.Press enter at the initial screen (to install in graphics mode).
3.After an initial scrolling of text the screen will blank and more text will 
appear.  This will be shifted noticeably to the right.  
4.The first blue“graphical” screen, titled “Welcome to Red Hat Enterprise 
Linux” will appear shifted right by one or more characters and may also be 
shifted downward one line.

Additional info:

Additional testing shows that this problem not only appears on ES1000, but 
also other manufacures cards
Comment 1 LisaWu 2007-01-16 22:12:13 EST
Created attachment 145769 [details]
shifted image during RHEL4 installation
Comment 2 LisaWu 2007-01-17 21:38:21 EST
RHEL4 install process chooses Vga16fb frame buffer driver to drive the 
console. 
Regardless of the mode set by video BOIS during linux setup period, the driver 
will modify video timing according to its hardcoded video parameters defined 
in structure fb_var_screeninfo. These parameters define the screen margins as 
well as the video resolution and result in the shifted screen. 

here is the detailed timing define by the vga16fb:
struct fb_var_screeninfo vga16fb_defined __initdata = {
     .xres               = 640,
     .yres               = 480,
     .xres_virtual       = 640,
     .yres_virtual       = 480,
     .bits_per_pixel     = 4,  
     .activate           = FB_ACTIVATE_TEST,
     .height             = -1,
     .width              = -1,
     .pixclock           = 39721,
     .left_margin        = 48,                     
     .right_margin       = 16,                      
     .upper_margin       = 39,                       
     .lower_margin       = 8,                      
     .hsync_len          = 96,
     .vsync_len          = 2,
     .vmode              = FB_VMODE_NONINTERLACED,
};
these hard coded parameter result in timing as follows:
640x480@59.4886Hz
HTimings:640 656 752 800
VTimings:480 488 490 529



Comment 3 Adam Jackson 2007-10-04 15:15:25 EDT
That's pretty awful, but it's not an X problem.  Reassigning to the kernel.
Comment 4 Jarod Wilson 2008-02-21 13:47:31 EST
Does this problem happen on rhel5 as well? Or do we use vesafb there instead of
vga16fb? The code in comment #2 looks exactly the same even in the latest
upstream kernel. Not sure if its easier to fix vga16fb or just switch to vesafb
instead...
Comment 5 LisaWu 2008-02-21 20:39:02 EST
Our customer hasn't found the same problem on rhle5. I found rhel5 doesn't use 
vga16fb as the console driver, correct me if I am wrong.
Comment 6 Jarod Wilson 2008-02-25 14:13:23 EST
Okay, a bit of further investigation says that rhel5 actually uses *no* fb
driver at all, just pure text mode. However, running that way generally isn't an
option on rhel4, due to some bits that still depend on the fb (primarily, CJK
characters). However, if CJK characters aren't needed, one can boot the
installer with 'linux nofb' and the offset problem *should* be gone. If that
does the trick, I think a release note about it might me more apropos than
fixing ancient code that (almost?) nobody uses in more modern kernels.
Comment 7 Jarod Wilson 2008-02-25 14:15:04 EST
Please let me know if 'linux nofb' does the trick, and if so, if this is an
acceptable workaround.
Comment 8 LisaWu 2008-02-26 20:38:32 EST
we accept this workaround. Thanks for your attention.
Comment 9 Jarod Wilson 2008-02-26 23:03:00 EST
Okay, I'll flag this bug to get a release note added for 4.7. Thanks much!
Comment 10 RHEL Product and Program Management 2008-02-26 23:08:44 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 Jarod Wilson 2008-02-26 23:19:41 EST
I hate the pm bot sometimes... Don't mind comment #10, we'll get the relnote in...
Comment 12 Don Domingo 2008-02-27 00:01:37 EST
tracking this bug for RHEL4.7 release notes.
Comment 13 Don Domingo 2008-03-17 20:54:34 EDT
adding to RHEL4.7 release notes under "Installation-Related Notes":

<quote>
When installing Red Hat Enterprise Linux 4 in Graphical Mode on systems that use
flat-panel monitors and some ATI cards, the screen area may appear shifted. When
this occurs, some areas of the screen will be obscured.

If this occurs, perform the installation with the parameter linux nofb.
</quote>

Jarod, please advise if any further revisions are required. thanks!
Comment 14 Jarod Wilson 2008-03-17 23:14:38 EDT
Its actually the text portions of the installer where we get the offset, not the
graphical -- see attachment. :)
Comment 15 Don Domingo 2008-03-18 00:02:39 EDT
whoops, missed that one. thanks for the catch, Jarod; source now reads:

<snip>
When installing Red Hat Enterprise Linux 4 in Text Mode...
</snip>
Comment 16 Don Domingo 2008-06-02 19:14:01 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.