Bug 222963 - When selecting cjk ttf font on xfontsel, FreeType: couldn't find encoding 'encoding...`
When selecting cjk ttf font on xfontsel, FreeType: couldn't find encoding 'en...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 23:04 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 23:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fonts.dir file in korean font directory (14.75 KB, text/plain)
2007-01-16 23:04 EST, sangu
no flags Details
grep results on rawhide (4.00 KB, application/octet-stream)
2007-10-31 00:16 EDT, Caius Chance
no flags Details

  None (edit)
Description sangu 2007-01-16 23:04:59 EST
Description of problem:
$cat /var/log/Xorg.log.0
[...]
(II) Mouse0: ps2EnableDataReporting: succeeded
FreeType: couldn't find encoding 'jisx0208.1983-0' for
'/usr/share/fonts/TrueType/Korean/Nbatang.ttf'
FreeType: couldn't find encoding 'adobe-standard' for
'/usr/share/fonts/TrueType/Korean/ngulim.ttf'
FreeType: couldn't find encoding 'adobe-standard' for
'/usr/share/fonts/TrueType/Korean/ngulim.ttf'
FreeType: couldn't find encoding 'adobe-standard' for
'/usr/share/fonts/TrueType/Korean/ngulim.ttf'


Version-Release number of selected component (if applicable):
3.0.9-24.fc7

How reproducible:
always

Steps to Reproduce:
1. Install cjk ttf font with ttmkfdir
2. Select cjk ttf on xfontsel.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2007-01-16 23:04:59 EST
Created attachment 145773 [details]
fonts.dir file in korean font directory
Comment 2 Liang Zhang 2007-10-23 05:06:14 EDT
I think this is the bug of fonts, not ttmkfdir.
Comment 3 Liang Zhang 2007-10-23 22:42:14 EDT
You can test it with fonts-chinese, fonts-korean and fonts-japanese.
I tested it with fonts-chinese, fonts-korean and fonts-japanese, and it is OK.
Comment 4 Caius Chance 2007-10-30 22:56:03 EDT
Hi sangu, could you please re-test on latest rawhide if the same problem exist?
I haven't found any of the mentioned Korean fonts in fonts-korean.

BTW FYI, fonts-korean had been updated into a meta-package which automates
installation of relevant Korean fonts when installation of fonts-korean is
triggered.
Comment 5 Caius Chance 2007-10-31 00:14:39 EDT
After installed fonts-korean package by yum:

*On F7*
$ grep -ir gulim /usr/share/fonts/korean
(returned no results)

*On Rawhude*
$ grep -ir gulim /usr/share/fonts/
(baemuk gulim and gulim family are shown correctly by xfontsel)
Comment 6 Caius Chance 2007-10-31 00:16:04 EDT
Created attachment 244071 [details]
grep results on rawhide
Comment 7 Caius Chance 2007-10-31 00:17:23 EDT
Please kindly provide more detailed bug reproduction procedures.
Comment 9 Jens Petersen 2007-10-31 01:45:06 EDT
I don't really understand

> FreeType: couldn't find encoding 'jisx0208.1983-0'

since it is common for Japanese fonts under Linux too.

> FreeType: couldn't find encoding 'adobe-standard' for
> FreeType: couldn't find encoding 'adobe-standard' for
> FreeType: couldn't find encoding 'adobe-standard' for

Can freetype handle these types of non-unix encoding?
Or is it just following X locale?

Sangu, why do you wish to use xfontsel?
Comment 10 sangu 2007-10-31 23:59:49 EDT
I referred xfontsel  for setting font of emacs-22.1.

Then, because of using emacs-unicode-2 recent, xfontsel is needless in my linux
life. 

hmm, Closed?


Note You need to log in before you can comment on or make changes to this bug.