Bug 22303 - System hangs hard during network initialization
System hangs hard during network initialization
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-14 11:33 EST by Ed Voncken
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 18:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Voncken 2000-12-14 11:33:16 EST
Problem description:
===============

Freshly installed (not upgraded) RH7.0 system hangs during network initialization.
The network card (3C905) is configured for DHCP auto-configuration.

Note: This system was previously running RH6.2, and exhibited no such problems

Hardware:
- Mainboard: Abit BP-6, no overclocking, BIOS 'NJ'
- CPU: 2x Celeron 366
- NIC: 3C905, installed in bottom PCI slot (shared PCI/ISA)

This problem was verified and reproduced on an identically configured machine.
Again, that machine was running RH6.2 before the re-installation without problems.

Using a different machine (single-CPU Celeron 433) with an identical network card,
the problem does NOT occur.

Impact:
=====
The system becomes essentially unusable after installation of Red Hat 7.0

Other symptoms:
============
One of the dual-Celeron systems spontaneously rebooted during unattended installation,
presumably related to this problem This has NOT been reproduced; the cause of the
reboot could not be determined..

Note:
====
Bugzilla requires a 'component'. I could not find an appropriate component, so I really had to guess ;)

=== EOF ===
Comment 1 Bill Nottingham 2000-12-14 11:37:44 EST
It hangs at 'Determining IP information for eth0'?

What's your /etc/modules.conf look like?
Comment 2 Ed Voncken 2000-12-14 13:06:39 EST
No, not 'determining IP information'. It's happening at the boot-up messages ("Bringing up lo ... [OK] Bringing up eth0 ...").

The /etc/modules.conf looks like this:

alias eth0 3c59x
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci

Anyway, I think I'm closing in on the actual source of the problem. I tried booting a different kernel,
so instead of 'linux' (2.2.16-22smp) , I tried 'linux-up' (2.2.16-22). This makes a huge difference.

With current information, the problem could best be described as:

"pump hangs when running an SMP kernel (2.2.16-22smp)"

Test results:

Out of the 4 times I rebooted SMP, network initialization (pump) always hung.
Out of the 4 times I rebooted UP, pump initialized the network normally.

My initial classification should probably have read 'pump', not 'initscripts'.

On a sidenote, I've always had problems and issues with pump.
For example, my provider changed my IP address a while ago.
Pump just crashed and left the network unconfigured. This was with RH6.2,
with all updates applied. Other RH6.2 machines, where I manually replaced
pump with dhcpcd, never had any such problems.

Hope this helps!

Greetings,
  Ed.
Comment 3 Bill Nottingham 2000-12-14 19:07:34 EST
If you let it sit there for 5-10 minutes, does it time out, or is
the system totally wedged?
Comment 4 Ed Voncken 2000-12-14 19:14:45 EST
I've left the system for at least 10 minutes, and it appears wedged (no CapsLock/NumLock response, for example).

I suspect some form of deadlock that is triggered on SMP kernels, but I don't know how to extract more meaningful data.
Would the SysRq key help? Could you give me some hints?
Comment 5 Bill Nottingham 2000-12-26 00:47:16 EST
sysrq *might* help.
Assigning to kernel.
Comment 6 Arjan van de Ven 2001-01-16 11:51:13 EST
There seems to be a bug with the 3com cards vs DHCP on SMP machines.
I've now seen several reports of it, and so far it seems 2.2.14 was fine, and
booting UP
is also fine. The maintainer of the 3com driver has been able to reproduce it
and is
chasing this bug hard. 

It _might_ be "pump" related,  could you try installing the "dhcpcd" package and
remove the
"pump" package to see if changing the dhcp client makes a difference ?
Comment 7 Ed Voncken 2001-01-20 13:41:42 EST
Additional testing has been performed with pump and dhcpcd.

System locks up in SMP using pump-0.8.3-2; same behaviour when pump is
deinstalled and subsequently dhcpcd-1.3.18pl8-6 is used. Booting Linux UP does 
not exhibit the problem.

All updates from updates.redhat.com were applied (as of 2001.01.19). Kernel is 
still at 2.2.16-22.

Since booting Linux SMP results in lockup with pump AND dhcpcd, the problem may 
indeed be 3Com NIC related; my network card is a 3Com 10/100 3C905. Info from 
lspci:

00:09.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 
30)

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.