Bug 22309 - content-type wrong for outgoing GPG-signed messages
Summary: content-type wrong for outgoing GPG-signed messages
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-14 19:37 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-25 09:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2000-12-14 19:37:10 UTC
When sending a GPG-signed message using Pine (via the gpg-sign filter), the
content-type is 'text/plain' rather than 'application/gpg; x-action=...'.

This means that if the receiver is using something a real mail client like
mutt ( ;-) ), they have to use procmail to fix up the content-type first
(or do it by hand).

To reproduce: send mail with pine and sign it; read the mail using mutt.

Comment 1 chappa 2000-12-28 03:34:49 UTC
This is not a bug in Pine. Pine allows you to change the content/type of a
message. I would say the bug is in the gpg-sign filter or the mistake is in the
way you use it. Did you use the  _MIMETYPE_ token when sending the mail?

Comment 2 Mike A. Harris 2001-01-28 20:32:43 UTC
I've read the relevant RFC's, and I agree that this is something that
should be fixed.  I don't consider it an extremely high priority though
because the pinegpg app has a few other problems and I am going to try
and find a better replacement for it if there is one out there.  If not,
I will look into this again some time before too long and fix it.

.



Comment 3 Mike A. Harris 2003-04-25 09:53:08 UTC
Going through deferred items.  pine is deprecated now, so closing this
as WONTFIX


Note You need to log in before you can comment on or make changes to this bug.