This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 223159 - Mangled Cross-Blending of Mozilla & SeaMonkey and Splitting Up of SeaMonkey
Mangled Cross-Blending of Mozilla & SeaMonkey and Splitting Up of SeaMonkey
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
: 223157 223158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-17 21:03 EST by John E. Koontz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 05:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John E. Koontz 2007-01-17 21:03:59 EST
Description of problem:

OK, technically, this is a problem with seamonkey, experienced in FC5, only 
you don't list a seamonkey component, and, anyway, this is partly due to 
seamonkey being drafted willy-nilly as the new mozilla component.  Also, it 
appears now that mozilla is no longer recognized as a component (product).  

Basically, people running mozilla are getting seamonkey, and mostly without 
mail functionality.  See actual results for details.   

Version-Release number of selected component (if applicable):

seamonkey-chat-1.0.7-0.6.fc5
seamonkey-dom-inspector-1.0.7-0.6.fc5
seamonkey-devel-1.0.7-0.6.fc5
seamonkey-js-debugger-1.0.7-0.6.fc5
seamonkey-mail-1.0.7-0.6.fc5
seamonkey-1.0.7-0.6.fc5

Replacing previous unitary seamonkey package and previous mozilla package.  


How reproducible:

Install FC 5 with or without the previous version of seamonkey from extras.  
Run yum update.

Different varieties of hell break loose depending on which starting state you 
had and whether you really want to run seamonkey or mozilla.   

Actual results:

I *think* this is what is happening:

If the old seamonkey (1.0.4, 1.0.5?) from extras was installed and you run yum 
update, you end up with an executable called /usr/bin/mozilla, but 
not /usr/bin/seamonky, that invokes seamonkey 1.0.7, and there is no mail or 
chat, etc., accessible anywhere - not in the menus, not in the footer icons, 
not by command line parameter.  

If you then get a glimmering and run yum install seamonkey-\* you get all the 
new subcomponent packages, but the mozilla executable is not aware of them.  
Same situation as before, but more packages.  

If you then delete seamonkey-* and everything that depends on it and reinstall 
them all, you end up with an executable called mozilla that has icons and a 
windows menu that knows about mail, etc., but mozilla -mail still doesn't 
work.   

If you have a system with no seamonkey on it and you run yum install seamonkey-
\* you end up with a setup in which mail is functional everywhere, but, of 
course, the executable is still called mozilla.   Anyway, it can see mail and 
mozilla -mail works.  It's not clear if it sees the same mail directories it 
saw before.  

Of course in all cases, the mozilla package is uninstalled for you.  Thanks, I 
guess.  

Expected results:

I would expect updating of seamonkey - now split into sub packages - to result 
in installing the subpackages, too.   Or maybe in would install a stub that 
told me to start from scratch with the new model.  Or it would never update 
and I would eventually realize I needed to install seamonkey-newsetup-\*.  I 
wouldn't expect mail to go away, causing users with custom setups that run 
seamonkey -mail &s to be unable to access mail.   

I would expect the principle executable to retain its usual name, seamonkey.  
(Still there in the tarball for 1.0.7.)

I would expect mozilla to remain intact, or to be deleted by some sort of 
mozilla update that installed either a link to seamonkey or something that 
explained that mozilla was gone, please remove this package and switch to 
seamonkey.   

Additional info:

- Crossbreeding the two packages by interrelating their updating behavior was 
wrong.
- Renaming the seamonkey executable was wrong.
- Not installing all the subdivided elements of seamonkey was wrong.

On the bright side, it ought to be easy to fix.  Harder to explain, maybe. :-)

Incidentally, I was really pleased to see that Xft is now compiled in.  So at 
least it is now easier to see MathML pages.  And that nasty SELinux problem 
that caused the old seamonkey to crash unless some file properties were hand 
changed is gone, too.
Comment 1 John E. Koontz 2007-01-19 15:19:39 EST
This is essentially the same as 223157.   I had difficulties submitting it.  
JEK
Comment 2 Martin Stransky 2007-01-20 05:15:24 EST
*** Bug 223157 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2007-01-25 19:53:19 EST
*** Bug 223158 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2007-07-18 13:31:49 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 5 John E. Koontz 2007-07-19 16:45:51 EDT
This set of problems was resolved by a modification of the SeaMonkey packages 
subsequent to the complaint, back when Fedora 5 was still supported.  I 
assumed you were responding to the bug, but perhaps something else prompted 
the corrections.  Anyway, I withdraw the bug.  


Note You need to log in before you can comment on or make changes to this bug.