Bug 223176 - gtkpod: undefined symbol: itdb_device_set_mountpoint
Summary: gtkpod: undefined symbol: itdb_device_set_mountpoint
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libgpod   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-18 05:28 UTC by Jason Farrell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 09:46:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Farrell 2007-01-18 05:28:22 UTC
Description of problem:
With the libgpod currently in updates-testing (and the new compat-libgpod),
gtkpod crashes when attempting to mount the ipod by clicking the "Load Ipod(s)"
button.

Version-Release number of selected component (if applicable):
libgpod-0.4.2-0.1.fc6
compat-libgpod-0.3.2-0.1.fc6

Steps to Reproduce:
1. yum --enablerepo=updates-testing install libgpod
2. run gtkpod from the terminal then click the "load ipod" button
  
Actual results:
gtkpod crashes with the following error:
gtkpod: symbol lookup error: gtkpod: undefined symbol: itdb_device_set_mountpoint

Expected results:

Additional info:
Reverting to the previous version (libgpod-0.4.0-0.fc6) fixes the problem:
rpm -e --nodeps compat-libgpod libgpod && yum update

Comment 1 Alexander Larsson 2007-01-18 09:46:02 UTC
0.4.0 was never in fc6, because it is binary incompatible to the 0.3 version in
fc6 but doesn't change the soname. Where did you get that from, and if the
gtkpod is built against that i can understand why it crashes with the 0.3.2 in
the compat update. Thats not really a fedora issue though.

Comment 2 Jason Farrell 2007-01-18 20:26:15 UTC
Yeah, you're right - i didn't look closely enough at it. Both libgpod (0.4.0)
and gtkpod were provided by freshrpms, and the compat update wont place nice
with it.


Note You need to log in before you can comment on or make changes to this bug.