Bug 22318 - hwclock hangs when auto power on enabled
hwclock hangs when auto power on enabled
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: clock (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-14 17:56 EST by John Saare
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-28 17:21:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Saare 2000-12-14 17:56:13 EST
HW:
	Asus A7V mobo
	Athlon/T-bird 1Ghz
	256MB
	IDE drives
	SMC PCI network card
	GeForce 2 GTS display adapter
	SB Live sound

I would like the machine to power on at a fixed time, everyday.  I've
enabled the "Everyday"
(at 8am) automatic power feature of the mobo.  Regardless of whether the
machine is
powered on manually or allowed to come on automatically, the problem
manifests itself
regardless.

The problem is that when the system's BIOS settings specify auto power on, 
the invocation
of /sbin/hwclock by /etc/rc.d/rc.sysinit, hangs.  Just the process running
hwclock hangs.
If you ctl-C, the boot continues until logging is started, then the boot
will progress no
further.

Repeat by:

	1.  halt system
	2.  Bring up BIOS menu, enable auto power on feature, Everyday, 8am.
	3.  Save new BIOS settings.
	4.  Permit system to finish booting (it probably will succeed).
	5.  Halt system, power off system.
	6.  Power on, Boot system..., will probably hang in hwclock as specified
above.

To "fix":

	7.  reset system...
	8.  Bring up BIOS menu, disable auto power on
	9.  Continue booting (boot single user "linux -s").
	10.  System will probably hang in hwclock.
	11.  Hit ctl-C if/when it hangs during single user boot.
	12.  Not sure why..., but the following "fixes" the hang:

		#fsck /dev/hda1  (Always reports clean)
		#mount -o remount,rw /dev/hda1 / 
		#sync
		#halt

	13.  Power system off
	14.  Power on, and allow to boot normally, everything should be back to
normal.

I'll dig around on the Asus website when I can get access.  I know that
this may not be
a Redhat/Linux issue, but I thought it worth mentioning..., and in these
days of "Stage 2
power alerts", I'd like to be a good power citizen.
Comment 1 Florian La Roche 2003-02-28 17:21:40 EST
This has been the only report and it is not reproducable for me, so I am
closing this down.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.