Bug 223214 - resume takes 60 seconds on VIA EPIA CN13000
resume takes 60 seconds on VIA EPIA CN13000
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 09:29 EST by Jeroen Janssen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 13:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of suspend & resume on VIA EPIA CN13000 (19.23 KB, text/plain)
2007-01-18 09:29 EST, Jeroen Janssen
no flags Details
[PATCH] sata_via: add missing PM hooks (1009 bytes, patch)
2007-05-04 09:26 EDT, Jeroen Janssen
no flags Details | Diff

  None (edit)
Description Jeroen Janssen 2007-01-18 09:29:26 EST
Description of problem:

Suspend & Resume works "OK" on a VIA EPIA CN13000 (as in it doesn't crash).

HOWEVER... the resume takes about 60 seconds to complete, which isn't very funny
at all.

Version-Release number of selected component (if applicable):

kernel 2.6.19-1.2895.fc6

How reproducible:

allways

Steps to Reproduce:
1. Perform Suspend
2. Perform Resume

Actual results:

Upon Resume, the (text) console becomes visible and the last text visible is
"Enabling non-boot CPUs ..."

Then after about 60 seconds, the following text is printed and the console
switches back to X:

ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata1.00: (BMDMA stat 0x1)
ata1.00: tag 0 cmd 0xca Emask 0x4 stat 0x40 err 0x0 (timeout)
ata1: soft resetting port
ata1.00: configured for UDMA/133
ata1: EH complete
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ACPI: Sleep Button (CM) [SLPB]

Expected results:

Resume to succeed in ~5 seconds.

Additional info:
Comment 1 Jeroen Janssen 2007-01-18 09:29:26 EST
Created attachment 145921 [details]
dmesg output of suspend & resume on VIA EPIA CN13000
Comment 2 Jeroen Janssen 2007-02-02 10:32:29 EST
Same problem occurs on F7Test1 with:

kernel 2.6.19-1.2914.fc7 and
kernel 2.6.19-1.2917.fc7
Comment 3 Jeroen Janssen 2007-05-04 09:26:12 EDT
Hi,

This problem is solved by applying "[PATCH] sata_via: add missing PM hooks" from:

http://article.gmane.org/gmane.linux.ide/18457 , which i will also attach to
this bugreport
Comment 4 Jeroen Janssen 2007-05-04 09:26:55 EDT
Created attachment 154120 [details]
[PATCH] sata_via: add missing PM hooks
Comment 5 Jeroen Janssen 2007-05-29 05:23:47 EDT
This bug has been solved in Fedora 7 RC2. (tested with installing the livecd to
disk and performing suspend/resume with a SATA disk)

Note You need to log in before you can comment on or make changes to this bug.