Bug 223221 - boot from iSCSI volume fails because iscsiadm doesn't support -M flag
boot from iSCSI volume fails because iscsiadm doesn't support -M flag
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
: FutureFeature
Depends On:
Blocks: 246139 200224 228022 296411
  Show dependency treegraph
 
Reported: 2007-01-18 10:00 EST by Martin Wilck
Modified: 2009-06-19 08:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHEL-5.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 13:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Wilck 2007-01-18 10:00:27 EST
Description of problem:
Reboot after installation on iSCSI volume fails. 

Version-Release number of selected component (if applicable):
5.1.19-2.1 (RHEL5 RCS 6)

How reproducible:
always

Steps to Reproduce:
1. Install RHEL5 on iSCSI volume (using "advanced storage configuration")
2. Press "Ok" on "congratulations" screen
  
Actual results:
Root filesystem isn't found

Expected results:
Normal boot

Additional info:
No initial RAM disk is created during installation. The reason is that mkinitrd
calls "iscsiadm -M <sysfs file>" but iscsiadm (iscsi-iniator-utils
6.2.0.742-0.2.el5) doesn't support that flag and exits with an error.

Further remark: The EL5 rescue system apparently has no support for iSCSI
storage, so recovering from this problem is extremely tedious because the whole
iscsi system must be setup by hand. iSCSI support in the rescue system would be
highly desirable.
Comment 2 Mike Christie 2007-02-22 14:01:05 EST
The iscsiadm -M <sysfs file> is fixed in iscsi-initiator-utils-6.2.0.742-0.3.
And mkinitrd was fixed in 5.1.19.5-1. Here is the bugzilla:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221088

Do we want to keep this bugzilla open for the second part of the BZ asking for
rescue system support?
Comment 5 Peter Jones 2007-05-02 14:50:00 EDT
It's unclear from the comments on this bug - is this issue still a problem?
Comment 6 Mike Christie 2007-05-02 14:58:16 EDT
The bug where -M sysfs_file was not working is fixed. We have testers reporting
success.

The second part of the BZ that requests iscsi support for the rescue system is
still open. Not sure how you want to handle that. Open a new BZ for that request
or use this BZ?
Comment 7 Martin Wilck 2007-05-03 03:23:30 EDT
Peter: no, the problem has been solved shortly before RHEL5 GA. Installation on
iSCSI works fine now (see issue tracker #119765, though).

Mike: we haven't tried the rescue system for some time (precisely because the
installations worked well).
Comment 10 Larry Troan 2007-05-15 10:37:12 EDT
Adding beta blocker flag per Sly. This is not really a 5.1 beta blocker.
Comment 13 David Cantrell 2007-10-25 13:05:55 EDT
Closing this bug.  Open new bugs for secondary issues.  The original issue
stated in the summary has been fixed.

Note You need to log in before you can comment on or make changes to this bug.