Bug 223246 - Post install boot hangs during loading of initrd, GRUB bug?
Post install boot hangs during loading of initrd, GRUB bug?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 11:52 EST by David Rector
Modified: 2008-04-06 10:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 10:31:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Rector 2007-01-18 11:52:16 EST
Description of problem:

I have a brand new SD32G2B motherboard from Shuttle, and am having trouble
getting past the first boot after installing Fedora Core 6.

The Install DVD boots and runs just fine, completing the installation without
errors.

Then when the system is going through it's first boot, it loads the kernel, then
tries to load initrd and hangs.

I have installed Fedora Core 6 on dozens of other machines with no problem.

After searching the web, I suspect that my problem has is related to a bug in
Grub which overwrites system (BIOS ram?) RAM in some systems if the initrd is
bigger than 13MB.

My problem is that I am stuck like I have never been stuck before. How do I
workaround a primary booting problem with GRUB. Is there a command that I can
give Grub to work around this problem? Some people have claimed that LILO works
on these systems, how can I replace GRUB with LILO?

Thanks for your help.

Dave Rector
*:^)



Version-Release number of selected component (if applicable):
Fedora Core 6

How reproducible:
Every Time

Steps to Reproduce:
1. Install Fedora Core 6
2. Reboot
3. System hangs after trying to load initrd
  
Actual results:
System hangs at initrd

Expected results:
System should continue booting.

Additional info:
Comment 1 David Rector 2007-01-21 23:59:28 EST
OK, I managed to try the "initrd_nocopy" patch posted a few weeks ago on the
GRUB development list. There was no change in behavior. The system still hangs
after loading the initrd image, and before uncompressing the kernel.

Next I will try to figure out how to install some other boot manager...

Dave Rector
*:^)
Comment 2 David Rector 2007-01-27 10:29:07 EST
It looks like I'm on my own on this one. Bummer ...

There is no question now that there is some strange interaction between GRUB and
my motherboard/BIOS. Fedora Core 6 installs and boots fine on countless other
machines that I can in my lab, except this one. (Shuttle SD32G2B).

As mentioned earlier, the initrd_nocopy patch to GRUB did not solve the problem.
I downloaded the lastest version of the LILO source, 22.7.3, which would not
compile  because it said it was missing as86 and ld86? Can this be true?

Luckily, downloading the LILO binary was successful, and it ran under "rescue
mode". After some tweaking of the LILO configuration, I finally have a bootable
machine.

If anyone out there has a similar experience, LILO seems to work fine now, but
it would be nice to find out what is wrong with GRUB.

Dave Rector
*:^)
Comment 3 Bug Zapper 2008-04-04 01:39:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Jim McBeath 2008-04-04 19:28:20 EDT
I believe I had the same problem with Fedora Core 6, and I still
have it with Fedora 8.  I was able to boot from the Fedora 8 DVD
and install, but when it rebooted to complete the installation,
it printed out a few lines of text and hung.

If I select virtualization during installation, I am able to boot
and run kernel-xen successfully, so that's what I have been using.
While running the xen kernel I used yum to update my system to get
the latest regular kernel.  When I reboot and select that kernel
from grub, it hangs as above after printing out this text:

  Booting 'Fedora (2.6.24.4-64.fc8)'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.24.4-64.fc8 ro root=/dev/vg0/lv_f8root norhgb noquiet
   [Linux-bzImage, setup=0x2c00, size=0x1f0240]
initrd /initrd-2.6.24.4-64.fc8.img
   [Linux-initrd @ 0x37c2c000, 0x3c3cb2 bytes]

It should be saying "Uncompressing linux" here, but it hangs
before that.

I have tried each of the following with no effect:
    * Disable APIC Mode in my BIOS before booting.
    * Remove all arguments from the kernel boot line.
    * Add the following arguments to the kernel boot line:
        pci=nommconf irqpoll acpi=off noapic nolapic

My system is a Shuttle SD32G2 with an Intel Core 2 Duo processor
and SATA disks (currently two drives, but formerly one drive,
same problem).

I have tried this with the latest Fedora 8 kernel and grub in the
standard yum repository, currently kernel.i686 2.6.24.4-64.fc8 and
grub.i386 0.97-19.
Comment 5 Jim McBeath 2008-04-05 13:11:40 EDT
After reading David Rector's comment in this bug report about
"interaction between grub and my motherboard/BIOS", I started
googling for some new terms, and was able to find some information
that I had not found during any of my previous searches.

I found a page on an Ubuntu forum
    <http://ubuntuforums.org/archive/index.php/t-516864.html>
in which someone recommended upgrading the BIOS for the SD32G2.
I went to Shuttle's download page, found the downloads for the SD32G2 BIOS,
    <http://global.shuttle.com/download03.jsp?PI=247>
and saw this comment on BIOS version SD32S30D with update date 20070426:
    "2. Fixed can't install Linux with Dual Core CPU."
I downloaded the latest BIOS version (SD32S30E, update date 20070607)
and flashed my BIOS using the instructions at
    <http://www.nenie.org/misc/flashbootcd.html>.
After this I was able to boot into the regular kernel, no hang.

So it turns out this is not a Fedora bug nor a grub bug, but a BIOS bug
in the Shuttle SD32G2, and the solution is to upgrade the BIOS.  At least
now there is a bug report here with the solution, in case anyone else
is having this problem.
Comment 6 John Poelstra 2008-04-06 10:31:12 EDT
Thanks for all of your information and update.  Closing this bug as it is not a
Fedora bug.

Note You need to log in before you can comment on or make changes to this bug.