Bug 223262 - /var/lib/jbossas/server/$config/log does not point to /var/log/... in some cases
/var/lib/jbossas/server/$config/log does not point to /var/log/... in some cases
Status: CLOSED ERRATA
Product: Red Hat Web Application Stack
Classification: Retired
Component: jbossas (Show other bugs)
v1.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Deepak Bhole
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 14:16 EST by Deepak Bhole
Modified: 2007-04-18 13:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2007-0084
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-19 13:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2007-01-18 14:16:25 EST
Description of problem:
If a new config, say "ports-01" is created, and a directory
/var/log/jbossas/ports-01 already exists, /var/lib/jbossas/server/ports-01/log
is created as directory instead of a link to /var/log/jbossas/ports-01

Version-Release number of selected component (if applicable):
All releases

How reproducible:
Always

Steps to Reproduce:
1. Create /var/log/jbossas/ports-01
2. Create a "ports-01" config as described in the release notes (within the
default JBOSS_HOME)
3. Start the server. 
  
Actual results:
There are no logs in /var/log/jbossas/ports-01

Expected results:
Logs should be in /var/log/jbossas/ports-01
Comment 1 Len DiMaggio 2007-01-24 15:35:33 EST
In trying to verify this bug fix, I'm seeing this:

Information from V1.0 release note:
(https://engineering.redhat.com/docbot/rhel/rhel-5-0-0/html/en-US/Red_Hat_Application_Stack/Release_Notes/Release_Notes.html#differentports)

   1. Create a new file /etc/init.d/service-name which is a symlink to
/etc/init.d/jbossas, e.g:
      ln -s /etc/init.d/jbossas /etc/init.d/jbossas-ports-01

   2. Create a new config file for service-name, /etc/sysconfig/service-name.
The content of this file should be similar to /etc/sysconfig/jbossas, except
with instance specific values uncommented and updated, e.g:
      cp /etc/sysconfig/jbossas /etc/sysconfig/jbossas-ports-01. Uncomment and
update JBOSSCONF to ports-01 in /etc/sysconfig/jbossas-ports-01.

   3. Then add service-name for management by chkconfig, e.g:
      chkconfig --add jbossas-ports-01							

   4. To start/stop the service, simply: service service-name start/stop, e.g:
      service jbossas-ports-01 start


These commands:

ln -s /etc/init.d/jbossas /etc/init.d/jbossas-ports-01
cp /etc/sysconfig/jbossas /etc/sysconfig/jbossas-ports-01
vi /etc/sysconfig/jbossas-ports-01    (JBOSSCONF="ports-01")
chkconfig --add jbossas-ports-01
service jbossas-ports-01 start

Result in:

[root@dl385-02 jbossas]# pwd
/var/log/jbossas
[root@dl385-02 jbossas]# ll
total 32
drwxr-xr-x  2 jboss jboss 4096 Jan 24 15:14 all
drwxr-xr-x  2 jboss jboss 4096 Jan 23 17:27 default
-rw-r--r--  1 jboss jboss   77 Jan 24 15:17 jbossas-ports-01-ports-01
drwxr-xr-x  2 jboss jboss 4096 Jan 23 17:27 minimal

Comment 2 Deepak Bhole 2007-01-24 15:50:14 EST
Right. The jbossas-ports-01-ports-01 is just a file that contains the the
command that was used for startup I believe (that file is always
/var/log/jbossas/svcname-configname).

However, in addition to that, there should be a 
/var/log/jbossas-ports-01/ports-01/*.log

where the logs are. If the above dir doesn't exist or if the logs don't go
there, this bug need to remain open.
Comment 3 Len DiMaggio 2007-01-24 15:55:38 EST
Sorry about not mentioning that - the problem is that the:

/var/log/jbossas-ports-01/ports-01/*.log

dir/files are not created. (Even if the /var/log/jbossas/ports-01 dir is not
created before the test is performed.)

Comment 4 Len DiMaggio 2007-01-24 16:27:12 EST
Please disregard comment #1 - the problem is resolved:

ll /var/lib/jbossas/server/ports-01/log
lrwxrwxrwx  1 root root 34 Jan 24 16:12 /var/lib/jbossas/server/ports-01/log ->
/var/log/jbossas-ports-01/ports-01
Comment 6 Red Hat Bugzilla 2007-02-19 13:30:29 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0084.html

Note You need to log in before you can comment on or make changes to this bug.