Bug 22328 - perl-5.6.0 will not rebuild on RHL62 due to fhs patch
Summary: perl-5.6.0 will not rebuild on RHL62 due to fhs patch
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 06:04 UTC by Pekka Savola
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 20:34:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-12-15 06:04:55 UTC
perl-5.6.0-11 will not rebuild on RHL6x due to fhs patch forcing
the man page installation to /usr/share/man but %{_mandir} macro
in the spec file trying to find them from /usr/man.

%{_mandir} should probably be changed to /usr/share/man because
it won't work with any other options anyway..

Comment 1 kenneth_porter 2000-12-21 10:16:40 UTC
The problem is the FHS patch, which hard-codes the mandir in hints/linux.sh and lib/ExtUtils/MM_Unix.pm. I created an alternative spec file that disables 
the patch and passes the mandir macro to Configure. This handles the hints file, but not the MM_Unix.pm module. That file may need to be patched 
dynamically from some script in the spec file.

Comment 2 kenneth_porter 2000-12-21 10:25:23 UTC
I'd attach the revised spec file but I don't see that option for this bug entry in Bugzilla. Here's a context diff:

5c5
< Release: 11
---
> Release: 12
82c82,84
< %patch6 -p1 -b .fhs
---
> # patch to hints/linux.sh replaced with Configure option,
> # still need equivalent for lib/ExtUtils/MM_Unix.pm though...
> # %patch6 -p1 -b .fhs
107a110,111
> 	-Dman1dir=%{_mandir}/man1 \
> 	-Dman3dir=%{_mandir}/man3 \
184a189,191
> * Thu Dec 21 2000 Kenneth Porter <shiva@well.com>
> - Pass RPM mandir to Configure for pre-FHS systems
> 



Note You need to log in before you can comment on or make changes to this bug.