Bug 223280 - [RHEL4.5] SATA driver update
[RHEL4.5] SATA driver update
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 15:39 EST by Linda Wang
Modified: 2013-07-02 22:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 00:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linda Wang 2007-01-18 15:39:07 EST
Description of problem:

This patch "tops off" RHEL4 SATA with the latest bug fixes from
upstream. 

Version-Release number of selected component (if applicable):
2.6.9-40 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The only thing that's not really a bug fix is sata_nv ADMA
support on newer NVIDIA chipsets (but not new new NVIDIA, which are
AHCI).  But even ADMA could be considered a fix of sorts, because it
enables 64-bit DMA and fixes some high-CPU-usage complaints.

This also includes some minor fixes for power management support,
problems that only existed in the RHEL4 backport and not upstream.

Changes from the preliminary patch, posted earlier today, are minor:
cleaned up the diff to remove superfluous changes, and make sure that
diskdump support did not disappear.
Comment 2 RHEL Product and Program Management 2007-01-18 15:47:10 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jason Baron 2007-01-23 11:41:26 EST
committed in stream U5 build 44. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/
Comment 4 Jay Turner 2007-01-30 07:31:58 EST
QE ack for RHEL4.5.
Comment 7 Red Hat Bugzilla 2007-05-08 00:40:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.