Bug 2233124 - libipuz FTBFS with Sphinx 7.1+ in Fedora Rawhide
Summary: libipuz FTBFS with Sphinx 7.1+ in Fedora Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libipuz
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Davide Cavalca
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2225274
TreeView+ depends on / blocked
 
Reported: 2023-08-21 14:16 UTC by Karolina Surma
Modified: 2023-09-15 18:48 UTC (History)
1 user (show)

Fixed In Version: libipuz-0.4.4-1.fc38 libipuz-0.4.4-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-08 02:46:48 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab jrb libipuz merge_requests 31 0 None opened docs: fix build with sphinx 7.1.2 2023-09-04 22:45:38 UTC

Description Karolina Surma 2023-08-21 14:16:43 UTC
Documentation for libipuz fails to build in RPM:

+ sphinx-build-3 docs html
Running Sphinx v7.1.2
making output directory... done
WARNING: html_static_path entry '_static' does not exist

Extension error (sphinx.config):
Handler <function correct_copyright_year at 0x7fe717817e20> for event 'config-inited' threw an exception (exception: string index out of range)

The issue is that the upstream conf.py doesn't contain `copyright` in the correct format as documented in Sphinx:
It should be: '2008, Author Name' (source: https://www.sphinx-doc.org/en/master/usage/configuration.html#confval-copyright).
It is: 2023 (source: https://gitlab.gnome.org/jrb/libipuz/-/blob/master/docs/conf.py#L23)

The issue is only visible in the RPM build, not upstream. This inconsistency has been reported to Sphinx project: https://github.com/sphinx-doc/sphinx/issues/11627


Reproducible: Always

Steps to Reproduce:
Test locally in mock: 
$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/sphinx-7.1.2/fedora-rawhide-x86_64/ --no-clean your.src.rpm
$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/sphinx-7.1.2/fedora-rawhide-x86_64/ shell

Comment 1 Davide Cavalca 2023-09-04 22:40:54 UTC
Confirmed that this repros in the latest libipuz version as well

Comment 2 Fedora Update System 2023-09-05 05:05:23 UTC
FEDORA-2023-3107d5d9a2 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-3107d5d9a2

Comment 3 Fedora Update System 2023-09-05 05:05:41 UTC
FEDORA-2023-a4ad02d10a has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-a4ad02d10a

Comment 4 Fedora Update System 2023-09-06 01:23:41 UTC
FEDORA-2023-a4ad02d10a has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-a4ad02d10a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-a4ad02d10a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-09-06 01:32:21 UTC
FEDORA-2023-3107d5d9a2 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-3107d5d9a2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-3107d5d9a2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2023-09-08 02:46:48 UTC
FEDORA-2023-a4ad02d10a has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2023-09-15 18:48:50 UTC
FEDORA-2023-3107d5d9a2 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.