Bug 223328 - kernal bug noted when viewing log
kernal bug noted when viewing log
Status: CLOSED DUPLICATE of bug 224359
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 17:37 EST by James Abbott
Modified: 2014-06-18 03:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 07:16:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Abbott 2007-01-18 17:37:11 EST
Description of problem:

Not sure.  I just was viewing logs and saw error report.

Jan 18 04:02:50 web kernel: ------------[ cut here ]------------
Jan 18 04:02:50 web kernel: kernel BUG at lib/list_debug.c:65!
Jan 18 04:02:50 web kernel: invalid opcode: 0000 [#1]
Jan 18 04:02:50 web kernel: SMP 
Jan 18 04:02:50 web kernel: last sysfs file: /block/ram0/dev
Jan 18 04:02:50 web kernel: Modules linked in: cifs ip_conntrack_netbios_ns 
iptable_nat ip_nat ip_conntrack nfnetlink iptable_mangle iptable_filter 
ip_tables x_tables nls_utf8 autofs4 hidp rfcomm l2cap bluetooth sunrpc ipv6 
dm_multipath parport_pc lp parport floppy snd_intel8x0 snd_ac97_codec 
snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq 
snd_seq_device snd_pcm_oss snd_mixer_oss ohci1394 i2c_i810 snd_pcm i2c_algo_bit 
i2c_i801 ieee1394 i2c_core snd_timer snd soundcore snd_page_alloc ide_cd 
8139too cdrom serio_raw 8139cp pcspkr mii dm_snapshot dm_zero dm_mirror dm_mod 
ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Jan 18 04:02:50 web kernel: CPU:    0
Jan 18 04:02:50 web kernel: EIP:    0060:[<c04e555b>]    Not tainted VLI
Jan 18 04:02:50 web kernel: EFLAGS: 00010086   (2.6.18-1.2798.fc6 #1) 
Jan 18 04:02:50 web kernel: EIP is at list_del+0x23/0x6c
Jan 18 04:02:50 web kernel: eax: 00000048   ebx: e1e12aa0   ecx: c0671c50   
edx: 00000086
Jan 18 04:02:50 web kernel: esi: efced6c0   edi: c6f9e000   ebp: efcefe80   
esp: efcdfef8
Jan 18 04:02:50 web kernel: ds: 007b   es: 007b   ss: 0068
Jan 18 04:02:50 web kernel: Process events/0 (pid: 5, ti=efcdf000 task=efa80030 
task.ti=efcdf000)
Jan 18 04:02:51 web kernel: Stack: c0636fcc e1e12aa0 ab72c7e1 e1e12aa0 c04671cc 
efcc3b80 00000005 00000001 
Jan 18 04:02:51 web kernel:        efcedee4 efcedee0 00000005 efcedec0 00000000 
c04672cf 00000000 00000000 
Jan 18 04:02:51 web kernel:        efcefe80 efced6e4 efced6c0 efcefe80 c16f33c0 
00000282 c04686f1 00000000 
Jan 18 04:02:51 web kernel: Call Trace:
Jan 18 04:02:51 web kernel:  [<c04671cc>] free_block+0x63/0xdc
Jan 18 04:02:51 web kernel:  [<c04672cf>] drain_array+0x8a/0xb5
Jan 18 04:02:51 web kernel:  [<c04686f1>] cache_reap+0x53/0x117
Jan 18 04:02:51 web kernel:  [<c042fa48>] run_workqueue+0x83/0xc5
Jan 18 04:02:51 web kernel:  [<c0430340>] worker_thread+0xd9/0x10d
Jan 18 04:02:51 web kernel:  [<c0432807>] kthread+0xc0/0xed
Jan 18 04:02:51 web kernel:  [<c0405447>] kernel_thread_helper+0x7/0x10
Jan 18 04:02:51 web kernel: DWARF2 unwinder stuck at 
kernel_thread_helper+0x7/0x10
Jan 18 04:02:51 web kernel: Leftover inexact backtrace:
Jan 18 04:02:51 web kernel:  =======================
Jan 18 04:02:52 web kernel: Code: 00 00 89 c3 eb e8 90 90 53 89 c3 83 ec 0c 8b 
40 04 8b 00 39 d8 74 1c 89 5c 24 04 89 44 24 08 c7 04 24 cc 6f 63 c0 e8 52 c0 
f3 ff <0f> 0b 41 00 09 70 63 c0 8b 03 8b 40 04 39 d8 74 1c 89 5c 24 04 
Jan 18 04:02:52 web kernel: EIP: [<c04e555b>] list_del+0x23/0x6c SS:ESP 
0068:efcdfef8
Jan 18 04:02:52 web kernel:  <3>BUG: sleeping function called from invalid 
context at kernel/rwsem.c:20
Jan 18 04:02:52 web kernel: in_atomic():0, irqs_disabled():1
Jan 18 04:02:52 web kernel:  [<c0405876>] dump_trace+0x69/0x1af
Jan 18 04:02:52 web kernel:  [<c04059d4>] show_trace_log_lvl+0x18/0x2c
Jan 18 04:02:52 web kernel:  [<c0405f83>] show_trace+0xf/0x11
Jan 18 04:02:52 web kernel:  [<c0406080>] dump_stack+0x15/0x17
Jan 18 04:02:52 web kernel:  [<c043527e>] down_read+0x12/0x20
Jan 18 04:02:52 web kernel:  [<c042d420>] blocking_notifier_call_chain+0xe/0x29
Jan 18 04:02:52 web kernel:  [<c0423411>] do_exit+0x1b/0x776
Jan 18 04:02:52 web kernel:  [<c0405f24>] die+0x298/0x2bd
Jan 18 04:02:52 web kernel:  [<c0406669>] do_invalid_op+0xa2/0xab
Jan 18 04:02:52 web kernel:  [<c04051e9>] error_code+0x39/0x40
Jan 18 04:02:52 web kernel: DWARF2 unwinder stuck at error_code+0x39/0x40
Jan 18 04:02:52 web kernel: Leftover inexact backtrace:
Jan 18 04:02:52 web kernel:  [<c04e555b>] list_del+0x23/0x6c
Jan 18 04:02:52 web kernel:  [<c04671cc>] free_block+0x63/0xdc
Jan 18 04:02:52 web kernel:  [<c04672cf>] drain_array+0x8a/0xb5
Jan 18 04:02:53 web kernel:  [<c04686f1>] cache_reap+0x53/0x117
Jan 18 04:02:53 web kernel:  [<c042fa48>] run_workqueue+0x83/0xc5
Jan 18 04:02:53 web kernel:  [<c046869e>] cache_reap+0x0/0x117
Jan 18 04:02:53 web kernel:  [<c0430340>] worker_thread+0xd9/0x10d
Jan 18 04:02:53 web kernel:  [<c041ae7f>] default_wake_function+0x0/0xc
Jan 18 04:02:53 web kernel:  [<c0430267>] worker_thread+0x0/0x10d
Jan 18 04:02:53 web kernel:  [<c0432807>] kthread+0xc0/0xed
Jan 18 04:02:53 web kernel:  [<c0432747>] kthread+0x0/0xed
Jan 18 04:02:53 web kernel:  [<c0405447>] kernel_thread_helper+0x7/0x10
Jan 18 04:02:53 web kernel:  =======================


Version-Release number of selected component (if applicable):


How reproducible:

only noted in log, only noted one time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Frey 2007-02-13 12:43:58 EST
I see a very similar thing, happens perhaps once a week
(output from Feb 13th):
BUG: unable to handle kernel paging request at virtual address 00002074
 printing eip:
c04f3b55
*pde = 71bb1067
Oops: 0000 [#1]
SMP
last sysfs file: /class/scsi_host/host2/proc_name
Modules linked in: hwmon i2c_isa eeprom sunrpc ipv6 ip_nat_sip ip_nat_pptp 
ip_nat_ftp ip_conntrack_sip ip_conntrack_pptp ip_conntrack_ftp xt_helper ipt_LOG 
xt_state xt_tcpudp iptable_mangle iptable_nat ip_nat ip_conntrack nfnetlink 
iptable_filter ip_tables x_tables dm_mirror dm_multipath dm_mod video sbs i2c_ec 
button battery asus_acpi ac lp snd_hda_intel snd_hda_codec snd_seq_dummy 
snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss 
sg snd_pcm snd_timer ide_cd floppy snd serio_raw cdrom sky2 ohci1394 ieee1394 
soundcore pcspkr iTCO_wdt skge i2c_i801 snd_page_alloc i2c_core parport_pc 
parport ata_piix libata aacraid sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd 
uhci_hcd
CPU:    0
EIP:    0060:[<c04f3b55>]    Not tainted VLI
EFLAGS: 00010046   (2.6.19-1.2895.fc6 #1)
EIP is at list_del+0x2d/0x6c
eax: 00002070   ebx: f76f0f80   ecx: 00000001   edx: 00000000
esi: f7ff8dc0   edi: d6ca8000   ebp: f7e6f380   esp: f7fefef0
ds: 007b   es: 007b   ss: 0068
Process events/0 (pid: 8, ti=f7fef000 task=f7e205d0 task.ti=f7fef000)
Stack: f7e205d0 d7ade040 f7ff8d40 f76f0f80 c04717fc f703e0c0 c07a2fc8 f703e0c0
       00000001 00000000 f7ff8e60 f7ff8e60 00000001 f7ff8e40 00000000 c04718ff
       00000000 00000000 f7e6f380 f7ff8de4 f7ff8dc0 f7e6f380 f7e0bac0 00000282
Call Trace:
 [<c04717fc>] free_block+0x77/0xf0
 [<c04718ff>] drain_array+0x8a/0xb5
 [<c0472e9c>] cache_reap+0x53/0x117
 [<c04368c7>] run_workqueue+0x97/0xdd
 [<c0437284>] worker_thread+0xd9/0x10d
 [<c0439810>] kthread+0xc0/0xec
 [<c0404c03>] kernel_thread_helper+0x7/0x10
 =======================
Code: c3 83 ec 0c 8b 40 04 8b 00 39 d8 74 1c 89 5c 24 04 89 44 24 08 c7 04 24 bc 
7e 65 c0 e8 86 3f f3 ff 0f 0b 41 00 f9 7e 65 c0 8b 03 <8b> 40 04 39 d8 74 1c 89 
5c 24 04 89 44 24 08 c7 04 24 0a 7f 65
EIP: [<c04f3b55>] list_del+0x2d/0x6c SS:ESP 0068:f7fefef0
 <3>BUG: sleeping function called from invalid context at kernel/rwsem.c:20
in_atomic():0, irqs_disabled():1
 [<c0405018>] dump_trace+0x69/0x1b6
 [<c040517d>] show_trace_log_lvl+0x18/0x2c
 [<c0405778>] show_trace+0xf/0x11
 [<c0405875>] dump_stack+0x15/0x17
 [<c043c402>] down_read+0x12/0x28
 [<c0433efe>] blocking_notifier_call_chain+0xe/0x29
 [<c0429f94>] do_exit+0x1b/0x787
 [<c0405719>] die+0x2c3/0x2e8
 [<c0627475>] do_page_fault+0x41c/0x4ef
 [<c0625ce1>] error_code+0x39/0x40
 [<c04f3b55>] list_del+0x2d/0x6c
 [<c04717fc>] free_block+0x77/0xf0
 [<c04718ff>] drain_array+0x8a/0xb5
 [<c0472e9c>] cache_reap+0x53/0x117
 [<c04368c7>] run_workqueue+0x97/0xdd
 [<c0437284>] worker_thread+0xd9/0x10d
 [<c0439810>] kthread+0xc0/0xec
 [<c0404c03>] kernel_thread_helper+0x7/0x10
 =======================
BUG: spinlock lockup on CPU#0, submit_check_re/26666, f7ff8de4 (Not tainted)
 [<c0405018>] dump_trace+0x69/0x1b6
 [<c040517d>] show_trace_log_lvl+0x18/0x2c
 [<c0405778>] show_trace+0xf/0x11
 [<c0405875>] dump_stack+0x15/0x17
 [<c04f39af>] _raw_spin_lock+0xbf/0xdc
 [<c0471b28>] cache_alloc_refill+0x74/0x4d0
 [<c0471aaa>] kmem_cache_alloc+0x50/0x5a
 [<c047d2e6>] getname+0x1a/0xb0
 [<c0402323>] sys_execve+0xe/0x4f
 [<c040404b>] syscall_call+0x7/0xb
 [<004d4402>] 0x4d4402
 =======================

Or before on the 5th (in this case the kernel is tainted since
I had the nvida module loaded):
Feb  5 20:36:48 blue kernel: BUG: unable to handle kernel paging request at 
virtual address 00002074
Feb  5 20:36:48 blue kernel:  printing eip:
Feb  5 20:36:48 blue kernel: c04f3b55
Feb  5 20:36:48 blue kernel: *pde = 6f02d067
Feb  5 20:36:48 blue kernel: Oops: 0000 [#1]
Feb  5 20:36:48 blue kernel: SMP
Feb  5 20:36:48 blue kernel: last sysfs file: /class/scsi_host/host2/proc_name
Feb  5 20:36:48 blue kernel: Modules linked in: autofs4 hwmon i2c_isa eeprom 
hidp l2cap bluetooth sunrpc ipv6 ip_nat_sip ip_nat_pptp ip_nat_ftp 
ip_conntrack_sip ip_conntrack_pptp ip_conntrack_ftp xt_helper ipt_LOG xt_state 
xt_tcpudp iptable_mangle iptable_nat ip_nat ip_conntrack nfnetlink 
iptable_filter ip_tables x_tables dm_mirror dm_multipath dm_mod video sbs i2c_ec 
button battery asus_acpi ac lp sg snd_hda_intel snd_hda_codec snd_seq_dummy 
snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss 
snd_pcm snd_timer ohci1394 snd soundcore ieee1394 ide_cd parport_pc pcspkr 
iTCO_wdt serio_raw snd_page_alloc skge sky2 cdrom parport nvidia(P)(U) i2c_i801 
floppy i2c_core ata_piix libata aacraid sd_mod scsi_mod ext3 jbd ehci_hcd 
ohci_hcd uhci_hcd
Feb  5 20:36:48 blue kernel: CPU:    1
Feb  5 20:36:48 blue kernel: EIP:    0060:[<c04f3b55>]    Tainted: P      VLI
Feb  5 20:36:48 blue kernel: EFLAGS: 00010046   (2.6.19-1.2895.fc6 #1)
Feb  5 20:36:48 blue kernel: EIP is at list_del+0x2d/0x6c
Feb  5 20:36:48 blue kernel: eax: 00002070   ebx: c21cf880   ecx: c21cf4e0   
edx: 00000000
Feb  5 20:36:48 blue kernel: esi: f7ff8dc0   edi: f0a3c000   ebp: f7e6f380   
esp: f7feeef0
Feb  5 20:36:48 blue kernel: ds: 007b   es: 007b   ss: 0068
Feb  5 20:36:48 blue kernel: Process events/1 (pid: 9, ti=f7fee000 task=f7e20070 
task.ti=f7fee000)
Feb  5 20:36:48 blue kernel: Stack: f7e20070 c21cf4c0 f7ff8dc0 c21cf880 c04717fc 
f71398c0 f7e5cfb0 f71398c0
Feb  5 20:36:48 blue kernel:        00000005 00000002 c21172e8 c21172e0 00000005 
c21172c0 00000000 c04718ff
Feb  5 20:36:48 blue kernel:        00000000 00000000 f7e6f380 f7ff8de4 f7ff8dc0 
f7e6f380 f7e0bcc0 00000282
Feb  5 20:36:48 blue kernel: Call Trace:
Feb  5 20:36:48 blue kernel:  [<c04717fc>] free_block+0x77/0xf0
Feb  5 20:36:48 blue kernel:  [<c04718ff>] drain_array+0x8a/0xb5
Feb  5 20:36:48 blue kernel:  [<c0472e9c>] cache_reap+0x53/0x117
Feb  5 20:36:48 blue kernel:  [<c04368c7>] run_workqueue+0x97/0xdd
Feb  5 20:36:48 blue kernel:  [<c0437284>] worker_thread+0xd9/0x10d
Feb  5 20:36:48 blue kernel:  [<c0439810>] kthread+0xc0/0xec
Feb  5 20:36:49 blue kernel:  [<c0404c03>] kernel_thread_helper+0x7/0x10
Feb  5 20:36:49 blue kernel:  =======================
Feb  5 20:36:49 blue kernel: Code: c3 83 ec 0c 8b 40 04 8b 00 39 d8 74 1c 89 5c 
24 04 89 44 24 08 c7 04 24 bc 7e 65 c0 e8 86 3f f3 ff 0f 0b 41 00 f9 7e 65 c0 8b 
03 <8b> 40 04 39 d8 74 1c 89 5c 24 04 89 44 24 08 c7 04 24 0a 7f 65
Feb  5 20:36:49 blue kernel: EIP: [<c04f3b55>] list_del+0x2d/0x6c SS:ESP 0068:
f7feeef0
Feb  5 20:36:49 blue kernel:  <3>BUG: sleeping function called from invalid 
context at kernel/rwsem.c:20
Feb  5 20:36:49 blue kernel: in_atomic():0, irqs_disabled():1
Feb  5 20:36:49 blue kernel:  [<c0405018>] dump_trace+0x69/0x1b6
Feb  5 20:36:49 blue kernel:  [<c040517d>] show_trace_log_lvl+0x18/0x2c
Feb  5 20:36:49 blue kernel:  [<c0405778>] show_trace+0xf/0x11
Feb  5 20:36:49 blue kernel:  [<c0405875>] dump_stack+0x15/0x17
Feb  5 20:36:49 blue kernel:  [<c043c402>] down_read+0x12/0x28
Feb  5 20:36:49 blue kernel:  [<c0433efe>] blocking_notifier_call_chain+0xe/0x29
Feb  5 20:36:49 blue kernel:  [<c0429f94>] do_exit+0x1b/0x787
Feb  5 20:36:49 blue kernel:  [<c0405719>] die+0x2c3/0x2e8
Feb  5 20:36:49 blue kernel:  [<c0627475>] do_page_fault+0x41c/0x4ef
Feb  5 20:36:49 blue kernel:  [<c0625ce1>] error_code+0x39/0x40
Feb  5 20:36:49 blue kernel:  [<c04f3b55>] list_del+0x2d/0x6c
Feb  5 20:36:49 blue kernel:  [<c04717fc>] free_block+0x77/0xf0
Feb  5 20:36:50 blue kernel:  [<c04718ff>] drain_array+0x8a/0xb5
Feb  5 20:36:50 blue kernel:  [<c0472e9c>] cache_reap+0x53/0x117
Feb  5 20:36:50 blue kernel:  [<c04368c7>] run_workqueue+0x97/0xdd
Feb  5 20:36:50 blue kernel:  [<c0437284>] worker_thread+0xd9/0x10d
Feb  5 20:36:50 blue kernel:  [<c0439810>] kthread+0xc0/0xec
Feb  5 20:36:50 blue kernel:  [<c0404c03>] kernel_thread_helper+0x7/0x10
Feb  5 20:36:50 blue kernel:  =======================

Let me know if you need additional information.
Comment 2 Martin Frey 2007-05-12 08:10:23 EDT
I still have the same problem happening perhaps once a week also with newer 
kernels (tested up to and including 2.6.20-1.2944.fc6).
Comment 3 Jeff Layton 2007-12-29 07:16:10 EST
This appears to be a dupe of bug 224359, please reopen if this is still
occurring in recent kernels.

*** This bug has been marked as a duplicate of 224359 ***

Note You need to log in before you can comment on or make changes to this bug.