Bug 22338 - can't run xauth -q -
Summary: can't run xauth -q -
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 10:54 UTC by K2
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 16:29:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description K2 2000-12-15 10:54:56 UTC
While trying to loging to remote host with ssh get error
	
	Could not run /usr/X11R6/bin/xauth -q -

Comment 1 Nalin Dahyabhai 2000-12-15 16:35:46 UTC
We configure OpenSSH to do X11 forwarding by default, and the xauth command is
used to set credentials on the remote machine.  If X is not installed, a failure
attempting to run xauth is harmless, and you can disable forwarding to make the
message going away by using ssh with the "-x" flag.

Comment 2 K2 2000-12-15 16:48:45 UTC
The problem is that X is installed and terminal hungs up when error appears

Comment 3 K2 2000-12-15 16:53:04 UTC
Terminal hungs up even if I disable forwarding to X

Comment 4 Nalin Dahyabhai 2000-12-15 16:57:55 UTC
Does /usr/X11R6/bin/xauth exist on both the client and server?  Are both systems
running OpenSSH?

Comment 5 K2 2000-12-15 16:59:34 UTC
Yes, I try to login to my own host 


Comment 6 K2 2000-12-15 18:44:21 UTC
I think the problem started from this error message :
 sshd[7412]: fatal: Read from socket failed: Connection reset by peer
 sshd[7790]: FATAL ERROR: ssh_privkey_read from /etc/ssh2/hostkey failed.

I don't know why sshd trys to read hostkey from /etc/ssh2 because I don't have
such directory

After I updated ssh to version 2.3.0p1-4 problem with xauth dissapeared but now
after establishing connection I have to press ^C to command line appears.

Comment 7 Pekka Savola 2001-01-01 13:07:41 UTC
You probably updated to OpenSSH from SSH.com SSH2 which left some dregs in configuration
files.

I got similar symptoms (sometimes) when trying to log on w/ xauth enabled when xauth didn't
exist: the connection was hung up.  I don't remember seeing it in 2.3.0p1+ though.


Comment 8 Tomas Mraz 2005-02-02 16:29:09 UTC
Yes, this is clearly a misconfiguration issue.



Note You need to log in before you can comment on or make changes to this bug.