Bug 223413 - powernow_k7 module missing
powernow_k7 module missing
Status: CLOSED DUPLICATE of bug 211941
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 20:24 EST by Benjamin LaHaise
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 10:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benjamin LaHaise 2007-01-18 20:24:05 EST
The kernel config (2.6.19-1.2895) does not include the K7 PowerNow module. 
Without this module, battery life is reduced significantly and this laptop runs
too hot.
# CONFIG_X86_POWERNOW_K7 is not set
Comment 1 Jarod Wilson 2007-01-19 10:25:33 EST
We actually build powernow-k7 into the kernel, not as a module, and it *is* enabled in the i686 kernel:

$ rpm -q --qf='%{name}-%{version}-%{release}.%{arch}\n' kernel
kernel-2.6.18-1.2869.fc6.i686
kernel-2.6.19-1.2895.fc6.i686

$ grep POWERNOW_K7 /boot/config-2.6.19-1.2895.fc6 
CONFIG_X86_POWERNOW_K7=y
CONFIG_X86_POWERNOW_K7_ACPI=y

I suspect you may have the i586 kernel installed instead of the i686 one. See http://fedoraproject.org/
wiki/Bugs/FC6Common.

*** This bug has been marked as a duplicate of 211941 ***

Note You need to log in before you can comment on or make changes to this bug.