Bug 223418 - JMB361: dma_base is invalid - causes hard lock just as the 2.6.19 kernel boots
JMB361: dma_base is invalid - causes hard lock just as the 2.6.19 kernel boots
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
Blocks: 427887
  Show dependency treegraph
Reported: 2007-01-18 21:32 EST by Brett Hoerner
Modified: 2008-02-07 23:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-07 23:29:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 128633 None None None Never

  None (edit)
Description Brett Hoerner 2007-01-18 21:32:06 EST
Description of problem:

After upgrading to kernel 2.6.19-1.2895 (and everything else up to date as of
01/18/07) I get the following message just after grub boots the kernel:

JMB361: dma_base is invalid
JMB361: dma_base is invalid

Then it hard locks, the HD light stays on full (see referenced ticket, this
happened to others before) and it stays there forever.  Does it every time,
going back to the old kernel 2.6.18-1.2869 works.

Version-Release number of selected component (if applicable):


Additional info:

HD:  Western Digital Caviar WD2500KS
Motherboard:  GIGABYTE GA-965P-S3, info here:
Comment 1 Brett Hoerner 2007-01-18 21:57:01 EST
Without 'quiet' on,

JMB361: chipset revision 2
JMB361: 100% native mode on irq 17
JMB361: dma_base is invalid
ide0: JMB361 Bus-Master DMA disabled (BIOS)


It booted properly when I set an option in BIOS (although it worked fine the
other way in 2.6.18 if you recall),

SATA Port0-3 Native Mode: Native IDE

(it was previously set to Legacy IDE)
Comment 2 Karsten Nyblad 2007-01-27 09:33:18 EST
I had the same problem and bypassed it by changing the BIOS option as described
by  Brett Hoerner.

I get the same error messages on JMB361 as Brett Hoerner.
Comment 3 Konstantin 2007-03-01 14:01:57 EST
I have the same problem (kernel-2.6.19-1.2911.fc6, GIGABYTE GA-965P-S3
motherboard). Brett's method allowed me to boot, but error message still appears
JMB363: dma_base is invalid
Also, older kernel worked fine.
Comment 4 Jon Stanley 2008-01-07 20:55:46 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)


I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 5 Jon Stanley 2008-02-07 23:29:07 EST
Per the previous comment in this bug, I am closing it as INSUFFICIENT_DATA,
since no information has been lodged for over 30 days.

Please re-open this bug or file a new one if you can provide the requested data,
and thanks for filing the original report!

Note You need to log in before you can comment on or make changes to this bug.