Bug 223433 - Kernel panic on install on 64BG EM64T
Kernel panic on install on 64BG EM64T
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 05:12 EST by Bastien Nocera
Modified: 2010-10-22 03:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sparsemem memmap allocation above 4G (2.31 KB, patch)
2007-07-10 18:33 EDT, Geoff Gustafson
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2007-01-19 05:12:05 EST
This issue is opened to track the same problem, but with the BOOT kernel as used
in the installer.

+++ This bug was initially created as a clone of Bug #173895 +++

Using RHEL4 U2's installer, a 64GB EM64T machine would panic on bootup with:
  Kernel panic - not syncing: map_single: bounce buffer is not DMA'ble 

"
The problem is because of mem_map using up most of the low memory (because of
64GB physical memory) and kernel is not  able to allocate swiotlb buffer in low
memory. We have verified that things work fine by moving the swiotlb init earlier.
"

Patch from venkatesh.pallipadi@intel.com attached.

-- Additional comment from bnocera@redhat.com on 2005-11-22 05:32 EST --
Created an attachment (id=121337)
swiotlb_init_07.patch


-- Additional comment from bnocera@redhat.com on 2005-11-22 05:32 EST --
The patch has already been forwarded to Larry Woodman by Intel, in private.

-- Additional comment from lwoodman@redhat.com on 2005-11-24 11:45 EST --

This patch will work but another/better solution is to move the mem_map above
the 4GB boundary.  There is no reason that it needs to be at such a low address.
I'll work with Intel on creating a patch that does this.

Larry Woodman

-- Additional comment from grgustaf@redhat.com on 2006-06-15 15:55 EST --
The problem is, the largesmp kernel works, but the installer/UP kernel doesn't.
Since this is the first time they've had ISOs, they only saw it now. In the
future, Intel will plan to test with UP kernel as well. Intel is working on a
patch that will solve this for the UP kernel, and we'll go from there.
Comment 1 RHEL Product and Program Management 2007-05-09 04:10:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Geoff Gustafson 2007-05-22 12:25:44 EDT
This was reproduced by Intel yesterday on 4.5 GA, FYI.
Comment 3 Larry Woodman 2007-07-10 11:36:48 EDT
Whats the status of this bug?  We expected a patch from Intel since we havent
reproduced the problem here at Red Hat.

Larry
Comment 4 Geoff Gustafson 2007-07-10 18:33:11 EDT
Created attachment 158909 [details]
sparsemem memmap allocation above 4G

Here's the 4.6 backport of what went upstream. It applies against the latest
55.16 kernel.
Comment 5 Jason Baron 2007-07-29 09:33:56 EDT
committed in stream U6 build 55.25. A test kernel with this patch is available
from http:/ /people.redhat.com/~jbaron/rhel4/
Comment 8 John Poelstra 2007-08-29 13:05:19 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 9 John Poelstra 2007-09-05 18:26:49 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 10 John Poelstra 2007-09-11 20:42:31 EDT
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 11 John Poelstra 2007-09-20 00:30:55 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6-Snapshot3 on partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 13 errata-xmlrpc 2007-11-15 11:18:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.