Bug 223437 - Installer failure with adaptec raid cards that use i2o driver ( fc6 )
Installer failure with adaptec raid cards that use i2o driver ( fc6 )
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Depends On:
  Show dependency treegraph
Reported: 2007-01-19 05:57 EST by Joni Bäcklund
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-14 17:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Kudzu-Probe output (1.24 KB, text/plain)
2007-01-30 13:54 EST, Joni Bäcklund
no flags Details

  None (edit)
Description Joni Bäcklund 2007-01-19 05:57:35 EST
Description of problem:

installer fails on adaptec i2o raid arrays. 

I have FC4 installation on my server today I was trying to update the system to 
FC6 without success. 
The installer probes the i2o and install the required drivers ok. Anaconda does
not make device nodes for the card. They shall be on /dev/i2o as /dev/i2o/hda1
and so on. So the installer does not see any disks on this machine at all while
the kernel has the driver ok. 

I did make the required nodes with mknod in console F3 shell. And the devices
were ok but still the installer claims that there are no devices at all. 

So, in short. You can not install or upgrade FC6 with this adapter with i2o raid
array driver.

Version-Release number of selected component (if applicable):

How reproducible:
just start instalkl

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jeremy Katz 2007-01-29 14:39:41 EST
Can you provide the output of running kudzu-probe from tty2?
Comment 2 Joni Bäcklund 2007-01-30 13:54:58 EST
Created attachment 146951 [details]
Kudzu-Probe output
Comment 3 Joni Bäcklund 2007-01-30 13:57:02 EST
So. There is the whole output from kudzu-probe at attachment. 

But here are the lines about raid controller:

 Scanning for SCSI Controllers
   Device Adaptec (formerly DPT) SmartRAID V Controller:
      Desc:           Adaptec (formerly DPT) SmartRAID V Controller
      Driver:         i2o_block
      Device:         None
Comment 4 Need Real Name 2007-04-12 14:40:01 EDT
Today I compared and contrasted attempted installs of both FC6 and RHEL5 on a
SuperMicro 6013P-8 with Adaptec 2015S Zero-Channel RAID card (i2o). RHEL5
installs fine (but does not auto-detect and load the i2o driver) and FC6 fails
entirely (both require a noprobe boot and manual selection of i2o). I had tried
the same thing you had here before finding this bugzilla report, manually making
an 80,0 "hda" dev node in /dev/i2o/  Anyway, comparing FC6 to RHEL5 I noticed
this additional line in /tmp/anaconda.log for FC6:

DEBUG : exception checking disk blacklist on i2o!hda: (2, 'No such file or
Comment 5 Scott Becker 2007-05-01 11:32:13 EDT
I'm having the exact same issue, same results from kudzu-probe.
Adaptec 2100S Raid Controller

I have RHEL 5 installed as a test bed but I also use it as a desktop. RHEL 4
worked fine as a desktop but 5 is stripped of apps so I need FC6...
Comment 6 Scott Becker 2007-05-01 13:17:28 EDT
(In reply to comment #5)
> I'm having the exact same issue, same results from kudzu-probe.
> Adaptec 2100S Raid Controller

I just tried Fedora 7 test 4 and it worked good. I suppose it's a little late to
fix 6...
Comment 7 David Cantrell 2007-08-14 17:34:17 EDT
Closing based on comment #6.

Note You need to log in before you can comment on or make changes to this bug.