Bug 223476 - Logrotate should ignore Cfengine files
Logrotate should ignore Cfengine files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 11:30 EST by Josh Kelley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.7.4-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 07:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Kelley 2007-01-19 11:30:43 EST
Cfengine, a popular administration and configuration tool that's provided in
Fedora Extras, may create backup files with a .cfsaved extension of files that
it modifies or replaces.

It would be useful if logrotate ignored all *.cfsaved files, just like
it currently ignores *.{rpmsave,rpmorig,rpmnew,swp,v,~}.

Version-Release number of selected component (if applicable):
3.7.4-7

How reproducible:
always

Steps to Reproduce:
1. Let Cfengine modify file /etc/logrotate.d/foo and back up the file before
modification as /etc/logrotate.d/foo.cfsaved.
2. Wait until 4:00am.
  
Actual results:
Logwatch complains about duplicate log entries in /etc/logrotate.d/foo*.

Expected results:
/etc/logrotate.d/foo.cfsaved is ignored.

Additional info:
Comment 1 Peter Vrabec 2007-04-02 05:59:31 EDT
Does it just complain, or it stops working? In case everything work OK, I 
really don't like to ignore these files automatically. Note you can set it 
manually by tabooext option.
Comment 2 Josh Kelley 2007-04-02 16:12:40 EDT
It looks like it stops working.

I hadn't seen the tabooext option, so I'll start using that.

Even though that option is present, though, it seems like it would be worth
having things work "out of the box", and I suspect that Cfengine is popular
enough to make handling it in particular worthwhile.  (I could be wrong.)

crontabs' /usr/bin/run-parts, for example, ignores *.cfsaved files.

Thanks.
Comment 3 Tomas Smetana 2007-05-14 08:52:23 EDT
Patch for ignoring .cfsaved files was committed (to be consistent with crontabs
package) and will be present in the next update.
Comment 4 Josh Kelley 2007-05-14 09:55:19 EDT
Thank you.
Comment 5 Fedora Update System 2007-05-14 13:17:48 EDT
logrotate-3.7.4-13.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.