Bug 223519 - odd output from ccs_tool update if qdiskd is in use.
odd output from ccs_tool update if qdiskd is in use.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 15:21 EST by Lon Hohberger
Modified: 2009-04-16 18:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix. (928 bytes, patch)
2007-01-23 10:17 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-01-19 15:21:01 EST
Description of problem:

In RHCS5, the node list includes 'node id 0' - which is the quorum device - if
one exists.

[root@war ~]# ccs_tool update /etc/cluster/cluster.conf
Failed to receive COMM_UPDATE_COMMIT_ACK from /dev/sdb1.
Hint: Check the log on /dev/sdb1 for reason.

Failed to update config file.
Comment 1 Lon Hohberger 2007-01-23 10:17:33 EST
Created attachment 146303 [details]
Fix.

[root@war ccs_tool]# ./ccs_tool update /etc/cluster/cluster.conf 
Config file updated from version 93 to 94

Update complete.
Comment 2 Lon Hohberger 2007-01-26 17:14:36 EST
Fix in RHEL5 / HEAD.
Comment 3 Lon Hohberger 2007-01-26 17:15:13 EST
Mine
Comment 5 Kiersten (Kerri) Anderson 2007-04-23 12:48:33 EDT
Fixing Product Name.  Cluster Suite was merged into Red Hat Enterpise Linux for
5.0.  In addition dlm, fence and ccs were merged into the cman package, so
bugzilla should reflect package name where those utilities are located.
Comment 7 RHEL Product and Program Management 2007-05-01 12:22:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Lon Hohberger 2007-06-29 13:24:05 EDT
To test this, simply try to do a ccs_tool update while qdiskd is running on the
cluster.  On 5.0, the update will fail because cman reports qdisk as a node
participating in the cluster.  On 5.1, this will succeed because cman will
ignore the phantom qdisk node.
Comment 10 Lon Hohberger 2007-06-29 13:24:22 EDT
Er, ccs will ignore the phantom qdisk node.
Comment 12 errata-xmlrpc 2007-11-07 11:59:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html

Note You need to log in before you can comment on or make changes to this bug.