Bug 223527 - No shell on tty2 during install
No shell on tty2 during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 15:44 EST by Jesse Keating
Modified: 2013-01-09 21:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 14:40:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-01-19 15:44:38 EST
Could be related to termcap/ncurses switch, but I can't get a shell on tty2. 
Some text about no /bin/sh
Comment 1 Will Woods 2007-01-19 15:47:33 EST
On my system I get an error trying to load libncurses.so.5, and bash fails to start.

This is extra fun when there's a traceback - because os.system() uses /bin/sh to
execute its arguments, you can't get around the lack of bash by using the python
debugger..
Comment 2 Jesse Keating 2007-01-19 15:54:53 EST
Yes, thats related to needing an rpm whiteout for ncurses.
Comment 3 Jeremy Katz 2007-01-29 14:40:09 EST
Fixed this.

Note You need to log in before you can comment on or make changes to this bug.