Bug 22356 - ENH: make gendiff ChangeLog-smart
Summary: ENH: make gendiff ChangeLog-smart
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 17:19 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-15 17:19:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's what I mean. (342 bytes, patch)
2000-12-15 17:19 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2000-12-15 17:19:27 UTC
I think it would be quite nice if gendiff used zero lines of context for
ChangeLog files.  That makes it easier for the resulting diff to apply,
since the ChangeLog entry just gets put at the top regardless of what's
currently at the top.

Comment 1 Tim Waugh 2000-12-15 17:19:54 UTC
Created attachment 6472 [details]
Here's what I mean.

Comment 2 Jeff Johnson 2000-12-16 18:59:33 UTC
Fixed in CVS, should be in rpm-4.0.2-0.4 when built.


Note You need to log in before you can comment on or make changes to this bug.