Bug 2235890 - [abrt] NetworkManager: g_mutex_clear(): NetworkManager killed by SIGABRT
Summary: [abrt] NetworkManager: g_mutex_clear(): NetworkManager killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 39
Hardware: ppc64le
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:da4c78d73c6fc718336f9690d71...
: 2237765 2237934 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-08-30 00:21 UTC by Trung Lê
Modified: 2023-09-30 00:18 UTC (History)
15 users (show)

Fixed In Version: glib2-2.78.0-3.fc40 glib2-2.78.0-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-26 00:13:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: proc_pid_status (1.17 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: maps (30.93 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: limits (1.29 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: environ (378 bytes, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: open_fds (2.98 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: mountinfo (3.59 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: os_info (756 bytes, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: cpuinfo (1.72 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: core_backtrace (13.47 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: dso_list (5.49 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: var_log_messages (15.63 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details
File: backtrace (60.69 KB, text/plain)
2023-08-30 00:21 UTC, Trung Lê
no flags Details

Description Trung Lê 2023-08-30 00:21:35 UTC
Description of problem:
Well I all did is to click on the top right corner then choose Wired as the connection and ABRT reports NetworkManager crashed

Version-Release number of selected component:
NetworkManager-1:1.44.0-1.fc39

Additional info:
reporter:       libreport-2.17.11
type:           CCpp
reason:         NetworkManager killed by SIGABRT
journald_cursor: s=c3329bad01b54b0daf866517f788d39b;i=3681;b=76af693e83bf40be93d65aaa8a9ba7ad;m=18a8996;t=6040455bae6df;x=cf338a766b78a0fb
executable:     /usr/sbin/NetworkManager
cmdline:        /usr/sbin/NetworkManager --no-daemon
cgroup:         0::/system.slice/NetworkManager.service
rootdir:        /
uid:            0
kernel:         6.5.0-0.rc7.20230821gitf7757129e3de.50.fc39.ppc64le
package:        NetworkManager-1:1.44.0-1.fc39
runlevel:       unknown
backtrace_rating: 4
crash_function: g_mutex_clear
comment:        Well I all did is to click on the top right corner then choose Wired as the connection and ABRT reports NetworkManager crashed

Truncated backtrace:
Thread no. 1 (7 frames)
 #3 g_mutex_clear at ../glib/gthread-posix.c:1450
 #5 lookup_data_free at ../gio/gthreadedresolver.c:251
 #6 g_task_finalize at ../gio/gtask.c:773
 #9 g_source_callback_unref at ../glib/gmain.c:1758
 #11 g_source_destroy_internal at ../glib/gmain.c:1423
 #13 g_main_context_dispatch_unlocked at ../glib/gmain.c:4284
 #14 g_main_context_iterate_unlocked.isra.0 at ../glib/gmain.c:4349

Comment 1 Trung Lê 2023-08-30 00:21:39 UTC
Created attachment 1985990 [details]
File: proc_pid_status

Comment 2 Trung Lê 2023-08-30 00:21:40 UTC
Created attachment 1985991 [details]
File: maps

Comment 3 Trung Lê 2023-08-30 00:21:42 UTC
Created attachment 1985992 [details]
File: limits

Comment 4 Trung Lê 2023-08-30 00:21:44 UTC
Created attachment 1985993 [details]
File: environ

Comment 5 Trung Lê 2023-08-30 00:21:45 UTC
Created attachment 1985994 [details]
File: open_fds

Comment 6 Trung Lê 2023-08-30 00:21:47 UTC
Created attachment 1985995 [details]
File: mountinfo

Comment 7 Trung Lê 2023-08-30 00:21:48 UTC
Created attachment 1985996 [details]
File: os_info

Comment 8 Trung Lê 2023-08-30 00:21:50 UTC
Created attachment 1985997 [details]
File: cpuinfo

Comment 9 Trung Lê 2023-08-30 00:21:51 UTC
Created attachment 1985998 [details]
File: core_backtrace

Comment 10 Trung Lê 2023-08-30 00:21:53 UTC
Created attachment 1985999 [details]
File: dso_list

Comment 11 Trung Lê 2023-08-30 00:21:55 UTC
Created attachment 1986000 [details]
File: var_log_messages

Comment 12 Trung Lê 2023-08-30 00:21:56 UTC
Created attachment 1986001 [details]
File: backtrace

Comment 13 Beniamino Galvani 2023-08-30 08:01:44 UTC
> #1  __GI_raise (sig=6) at ../sysdeps/posix/raise.c:26
> #2  __GI_abort () at abort.c:79
> #3  g_mutex_clear (mutex=<optimized out>) at ../glib/gthread-posix.c:1450
> #4  g_mutex_clear (mutex=<optimized out>) at ../glib/gthread-posix.c:1445
> #5  lookup_data_free (data=0x137ed9710) at ../gio/gthreadedresolver.c:251
> #6  g_task_finalize (object=0x137ee1ba0) at ../gio/gtask.c:773

Possibly related to this GLib change:

https://gitlab.gnome.org/GNOME/glib/-/commit/7b18e6205a03058541391e02c013c893b144e1ed

Reassigning.

Comment 14 Beniamino Galvani 2023-09-07 07:06:00 UTC
*** Bug 2237765 has been marked as a duplicate of this bug. ***

Comment 15 Beniamino Galvani 2023-09-07 20:20:49 UTC
*** Bug 2237934 has been marked as a duplicate of this bug. ***

Comment 16 dex 2023-09-18 03:50:03 UTC
breaks network till reboot... F39

Comment 17 dex 2023-09-20 07:46:36 UTC
Well at least I got to re-learn how to do networking without NetworkManager those were the days:-)

Comment 19 dex 2023-09-24 15:20:30 UTC
The Network is back so far with the F40 package.

Comment 20 Fedora Update System 2023-09-27 12:21:54 UTC
FEDORA-2023-849ae2b492 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-849ae2b492

Comment 21 Fedora Update System 2023-09-27 12:29:38 UTC
FEDORA-2023-7289d46f0d has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-7289d46f0d

Comment 22 Fedora Update System 2023-09-27 15:52:44 UTC
FEDORA-2023-849ae2b492 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2023-09-28 20:17:11 UTC
FEDORA-2023-7289d46f0d has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-7289d46f0d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-7289d46f0d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Fedora Update System 2023-09-30 00:18:06 UTC
FEDORA-2023-7289d46f0d has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.