Bug 223604 - kernel 2.6.19-1.2895.fc6 oops when suspend to disk with cpufreq_ondemand loaded
kernel 2.6.19-1.2895.fc6 oops when suspend to disk with cpufreq_ondemand loaded
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 12:36 EST by Roy Dragseth
Modified: 2015-03-04 20:18 EST (History)
10 users (show)

See Also:
Fixed In Version: pm-utils-0.99.4-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-30 16:23:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Content of /proc/cpuinfo and output hal-device (111.35 KB, text/plain)
2007-01-20 12:36 EST, Roy Dragseth
no flags Details
Output of /proc/cpuinfo and hal-device for T60p (108.77 KB, text/plain)
2007-01-25 19:18 EST, Paul W. Frields
no flags Details
A picture of the oops message dump. (204.69 KB, image/jpeg)
2007-02-13 06:11 EST, Roy Dragseth
no flags Details

  None (edit)
Description Roy Dragseth 2007-01-20 12:36:08 EST
Description of problem:
The latest and greatest fc6 kernel (2.6.19-1.2895.fc6) gives and oops when one 
tries suspend to disk with 

echo disk > /sys/power/state

This goes away when one stops cpuspeed first so the cpufreq_ondemand module 
get unloaded.  This was not necessary with the 2.6.18 line of kernels.

Version-Release number of selected component (if applicable):
kernel 2.6.19-1.2895.fc6

How reproducible:
echo disk > /sys/power/state


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This is on my dual core Asus S6F laptop.  You'll find the content of cpuinfo 
and the output of hal-device ganged together in the attachment.

I can probably provide a full oops info if needed, but I need to attach a 
bigger screen to make the whole content visible and to copy it off screen by 
hand.
Comment 1 Roy Dragseth 2007-01-20 12:36:09 EST
Created attachment 146060 [details]
Content of /proc/cpuinfo and output hal-device
Comment 2 Paul W. Frields 2007-01-25 19:17:52 EST
This also happens on my dual core T60p ThinkPad.  Thank you for the temporary
fix, by the way.  I'm not sure whether it's necessary, but I'm attaching similar
info for the T60p.
Comment 3 Paul W. Frields 2007-01-25 19:18:58 EST
Created attachment 146654 [details]
Output of /proc/cpuinfo and hal-device for T60p
Comment 4 Paul W. Frields 2007-01-26 08:48:20 EST
To any visiting this bug: A quick workaround is to add a script to /etc/pm/hooks
to stop the cpuspeed service before suspend, and start it after resume.  One
example that seems to work:

#!/bin/sh
case "$1" in
  suspend)
    /sbin/service cpuspeed stop ;;
  resume)
    /sbin/service cpuspeed start ;;
  *)
    ;;
esac
exit $?
# -=--=--=--=--=-- >8

There's a lot of nifty logic left out to make the example simple. :-)  If you
enable the workaround, and a kernel update hits the updates-testing repo (or, if
you're timid, the real updates repo), please disable this hook script to test
the fixes.  Just leaving a note here to make people's lives easier while they
wait for something to test.
Comment 5 Chuck Ebbert 2007-02-10 13:20:22 EST
Please try to provide the oops message if possible.

You can take a picture of the screen with a digital camera.
Comment 6 Andrea Dell'Amico 2007-02-11 12:00:57 EST
(In reply to comment #5)
> Please try to provide the oops message if possible.
> 
> You can take a picture of the screen with a digital camera.

How? The screen is already blank when the kernel crashes. Is there any suspend
hooks to disable?

NB: the 'service cpuspeed stop' workaround works for me too.
Comment 7 Roy Dragseth 2007-02-13 06:11:35 EST
Created attachment 147972 [details]
A picture of the oops message dump.

I finally managed to take a picture of the screen message by using an external
crt monitor.  The long backtrace makes the first lines of the message to scroll
off the top of the screen.  For some obscure reason I could not get the console
to stay in 80x60 mode, it starts booting with 80x60 res but somewhere further
down it resets to 80x25.

I hope you can make some sense of this.
Regards,
r.
Comment 8 Chuck Ebbert 2007-02-13 09:36:03 EST
Well, I can see what's happening but don't see a fix.

pm-utils should be handling this automatically AFAICT -- 
at least there are scripts there that look like they
try to do what your workaround does.
Comment 9 Chuck Ebbert 2007-02-13 10:15:14 EST
*** Bug 228275 has been marked as a duplicate of this bug. ***
Comment 10 Roy Dragseth 2007-02-14 16:17:05 EST
I guess this should be marked as a pm-utils bug rather than a kernel bug then.
The strange thing is that earlier kernels didn't have this problem, I wasn't 
using pm-utils earlier, just the good old hackish

echo disk > /sys/power/state

which bypasses all the safety measures taken in pm-hibernate and that worked 
just fine on the 2.6.18 line of kernels.

r.
Comment 11 Tru Huynh 2007-02-16 12:50:32 EST
Sony SZ3XP has the same behaviour:
pm-utils-0.19-3.x86_64
kernel-2.6.18-1.2869.fc6.x86_64 -> suspend ok
kernel-2.6.19-1.2911.fc6.x86_64 -> blank screen/no suspend unless cpuspeed is
turned off prior to suspension
refers to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223731 ?
Comment 12 Till Maas 2007-12-30 14:37:33 EST
Is this bug still present in Fedora 7 or 8?
Comment 13 Roy Dragseth 2007-12-30 16:16:34 EST
No, it seems to be fixed now.

Note You need to log in before you can comment on or make changes to this bug.