Bug 2236246 - Wireshark crashes when confirming which interfaces to hide within the "Managed Interfaces" window of the "Capture Options" section
Summary: Wireshark crashes when confirming which interfaces to hide within the "Manage...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 38
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michal Ruprich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-08-30 19:22 UTC by hirschmatthew9
Modified: 2023-09-15 18:45 UTC (History)
6 users (show)

Fixed In Version: wireshark-4.0.8-2.fc37 wireshark-4.0.8-2.fc38 wireshark-4.0.8-2.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-09 00:39:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
`backtrace` from Fedora's Problem Reporting application (164.39 KB, text/plain)
2023-08-30 19:23 UTC, hirschmatthew9
no flags Details
`core_backtrace` from Fedora's Problem Reporting application (42.35 KB, application/json)
2023-08-30 19:25 UTC, hirschmatthew9
no flags Details

Description hirschmatthew9 2023-08-30 19:22:10 UTC
Wireshark will crash a second or so after clicking the "OK" button in the "Managed Interfaces" window, which can be accessed via clicking on "Capture > Options" on the main toolbar.

Reproducible: Always

Steps to Reproduce:
1. Click on "Capture" then "Options" within the main toolbar on the top.
2. Click on the "Managed Interfaces" button on the bottom-right corner of the window that pops up.
3. Not sure if you have to uncheck the check mark box under the "Show" column for some of the interfaces shown, to successfully reproduce this. However, that's what I did the first few times I tried to reproduce this.
4. Click on the "OK" button in the bottom-right corner of that window.
Actual Results:  
Crashes around a second after clicking the "OK" button. Though, after reopening Wireshark, the changes seem to have been saved.

Expected Results:  
Should not crash.

Version: wireshark-1:4.0.7-2.fc38
Output of `uname --all`: Linux fedora 6.4.12-200.fc38.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Aug 23 17:46:49 UTC 2023 x86_64 GNU/Linux

Some of the raw crash report is shown below, more in the attachments:
reason: wireshark killed by SIGSEGV
crash_function: void doActivate<false>(QObject*, int, void**)

Comment 1 hirschmatthew9 2023-08-30 19:23:51 UTC
Created attachment 1986193 [details]
`backtrace` from Fedora's Problem Reporting application

Comment 2 hirschmatthew9 2023-08-30 19:25:28 UTC
Created attachment 1986194 [details]
`core_backtrace` from Fedora's Problem Reporting application

Comment 3 hirschmatthew9 2023-08-30 23:17:37 UTC
FYI, this issue exists upstream and was fixed. However, the issue author said they couldn't reproduce it in the version that I happen to be using (v4.0.7). Link to the relevant issue: https://gitlab.com/wireshark/wireshark/-/issues/19287

Comment 4 Michal Ruprich 2023-08-31 08:11:25 UTC
Thanks for the report, it was actually easily reproducible on F37 with the 4.0.7 version. I am adding this to the 4.0.8 rebase that I have prepared.

Comment 5 Fedora Update System 2023-08-31 13:52:44 UTC
FEDORA-2023-920a3ab4ee has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-920a3ab4ee

Comment 6 Fedora Update System 2023-08-31 13:52:59 UTC
FEDORA-2023-abc9ca1e7e has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-abc9ca1e7e

Comment 7 Fedora Update System 2023-08-31 13:53:15 UTC
FEDORA-2023-b57a9be8a8 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b57a9be8a8

Comment 8 Fedora Update System 2023-09-01 01:46:32 UTC
FEDORA-2023-b57a9be8a8 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b57a9be8a8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b57a9be8a8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2023-09-01 02:24:27 UTC
FEDORA-2023-920a3ab4ee has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-920a3ab4ee`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-920a3ab4ee

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-09-01 02:31:29 UTC
FEDORA-2023-abc9ca1e7e has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-abc9ca1e7e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-abc9ca1e7e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-09-09 00:39:53 UTC
FEDORA-2023-920a3ab4ee has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2023-09-09 01:34:48 UTC
FEDORA-2023-abc9ca1e7e has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2023-09-15 18:45:01 UTC
FEDORA-2023-b57a9be8a8 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.