Bug 223668 - yum fails update because of substandard mirror list
yum fails update because of substandard mirror list
Status: CLOSED DUPLICATE of bug 222517
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 12:45 EST by Stefan Axelsson
Modified: 2014-03-16 23:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 09:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Axelsson 2007-01-21 12:45:21 EST
Description of problem:

I'm located in Sweden. Apparently yum fetches a mirror list depending on my
location (verified empirically). The mirror list for Sweden (SE) contains only
one mirror that doesn't work (i.e. it is severely overloaded and refuses new
connections). Yum then fails with "no more mirrors", even though there are
several higher quality mirrors available but a few hops away (not in Sweden though).

This also affects the automatic updater applet thingy, but with less obvious
symptoms, the updater's progress bar just freezes with no indication to the user
as to the source of the problem.


Version-Release number of selected component (if applicable):

No.

How reproducible:

Close to always. Did a fresh Fedora Core 6 install and had to restart yum more
than twenty times to be able to finally fetch all updates (a process that took
close to eight hours). 

Steps to Reproduce:
1. Be in Sweden.
2. Run "yum update"
3. Watch the unbearably slow downloads (i.e. 10-15 seconds for the handshake for
each file) and a frequent occurrence of the error message: 

"Sorry the maximum number of allowed connections (50) to the repository have
already been used up (or words to that effect), No more mirrors to try."
  
Actual results:

Failed update or unbearably slow.

Expected results:

Same snappy performance as for Fedora Core 4, and no ramdom failures.

Additional info:

Far be it from me to suggest a fix instead of just reporting the bug, but
ideally; if yum must be configured with a subset of the available mirrors, then
that subset should be configurable by the user (there is nothing in the
documentation pertaining to this problem). If that's not possible, then the
mirror lists should be amended to avoid "single sourcing" sub standard mirrors
(as one that can only handle 50 simultanous connections certainly is) as in the
case of http://mirrors.fedoraproject.org/updates-released-fc6-SE-i386.txt" which
just contains: "ftp://falkor.skane.se/pub/mirrors/fedora/updates/6/$ARCH/"
compared to e.g. *global* which lists some 74 different mirrors. Coupled with
e.g. the yum plugin "fastestmirror" that could be the ticket (though I haven't
tried it).
Comment 1 Seth Vidal 2007-01-21 23:45:16 EST
This is mostly an infrastructure piece that needs to be changed somewhat.
Comment 2 Mike McGrath 2007-01-22 09:53:27 EST
Append "country=global" or "country=SE,DE,UK,FR,ES" to the end of the query
string.  A solution is being worked out.

*** This bug has been marked as a duplicate of 222517 ***

Note You need to log in before you can comment on or make changes to this bug.