Bug 223684 - gtk-doc manual not viewable in yelp
Summary: gtk-doc manual not viewable in yelp
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-doc   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-01-21 20:32 UTC by Paul W. Frields
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-30 03:01:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix help/manual/C/Makefile.in (604 bytes, patch)
2007-01-21 20:32 UTC, Paul W. Frields
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 403692 None None None Never

Description Paul W. Frields 2007-01-21 20:32:44 UTC
Description of problem:
The manual referred to in the OMF file has an incorrect URL, so it can't be
opened in yelp.

Version-Release number of selected component (if applicable):
1.7-1.fc6
1.7-2.fc7
(might want to check fc5 as well, didn't have a host handy)

How reproducible:
Every time

Steps to Reproduce:
1. Open yelp (F1)
2. Select "Programming" from listing on left
3. Select "GTK-Doc Manual"
  
Actual results:
URL is incorrect

Expected results:
Visible documentation

Additional info:
I'm attaching a patch that I think is OK.  I'm not sure why the
help/manual/C/Makefile.in refers to $(docdir) since it's not set as far as I can
tell.  Instead, the rest of the Makefile.in's are using $(gtkdochelpdir).  Sorry
if this is disingenuous, as I am a neophyte when it comes to autotools type stuff.

Comment 1 Paul W. Frields 2007-01-21 20:32:44 UTC
Created attachment 146107 [details]
Patch to fix help/manual/C/Makefile.in

Comment 2 Matthias Clasen 2007-02-02 20:22:54 UTC
Fixed in rawhide, building an FC6 update now.


Note You need to log in before you can comment on or make changes to this bug.