Bug 22373 - can't mount /tmp/sda
can't mount /tmp/sda
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-15 18:23 EST by Need Real Name
Modified: 2007-03-26 23:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 11:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Comment (399.73 KB, text/plain)
2000-12-15 18:23 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-12-15 18:23:38 EST
Created attachment 915074 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Michael Fulbright 2000-12-18 12:22:41 EST
Assigning to a developer.
Comment 2 Brent Fox 2000-12-18 12:37:46 EST
Can you tell me a few things?  

1) Was this in text mode?  (I'm assuming so.)  

2) What is the exact model and specs of the video card (RAM)?

3) Does the error occur in the exact same place every time and what step(s) does
it happen at?

4) Is this happening when you are testing X?

5) Is the installer reporting the correct monitor and video card settings?
Comment 3 Need Real Name 2000-12-18 14:22:36 EST
1) yes, this was in text mode, but  the reason that I was installing in text
mode is because this happens immediately when I try to install in graphics
mode...as soon as anaconda is loaded.  FYI:  It happens whether I install the
anaconda update or not

2)  The video card is a Diamond Viper V770 Ultra with 32MB VRAM and a RIVA TNT2
Ultra processor.  Memory clock speed is 183MHz and Core clock speed is 150MHz.

3) Yes, the error occurs in the exact same place every time.  In this instance,
it occurred while configuring the X Windows system.  When I choose to install in
graphical mode, it happens almost immediately....before it asks me which disk to
install on.

4) Yes, this is happening when the X Configurator is running.

5) I do not know if the installer is reporting the correct monitor and video
card settings...i will try installing again and let you know.
Comment 4 Need Real Name 2000-12-18 17:57:51 EST
I tried reinstalling to see if linux recognizes the video card and monitor, but 
I don't know where to find this information.
Comment 5 Brent Fox 2000-12-19 11:49:13 EST
Right after the Package Group Selection screen, you should see a window titled
"X probe results" that should tell you the type of video card and X server that
the installer has probed.  I'm curious to know what this says.

Also, try this.  Press Alt+F2 to go to a console.  Type "lspci".  You should see
a lot of information about devices on the PCI bus.  Do you see any lines that
start with anything like "VGA compatible controller"?  If so, what does the rest
of the line say?

Then, type "ddcprobe".  This should probe your video card and monitor.  You'll
see a bunch of information scroll by.  If you press Shift+PageUp, you can scroll
back up to the top.  The first bunch of lines should be information about the
video card and the rest of it should be about the monitor.  Can you tell me what
it says about the make and model of your video card and monitor?

For the time being, a workaround is to say "No" when asked if you want to test
your X configuration and then use Xconfigurator to set up your video card after
you are through installing.
Comment 6 Need Real Name 2000-12-19 13:32:03 EST
After the package group selection screen, it begins checking dependencies and 
then crashes.  I never see a window titled "X probe results".

As for the "lspci" command, it produced this line among others:
01:00.0 VGA Compatible Controller: nVidia Corporation Riva TnT2 [NV5] (rev 11)

Here are the significant lines resulting from the "ddcprobe" command:
For the video card:
    OEM Name: NVidia
    Product Name: Riva TNT
    Product Revision A5

For the monitor:
    Manufacturer: GWY
    Monitor details 2:
        Name: Gateway EV91

FYI: It's actually a EV910...I'm not sure if that matters.

So, in order for me to do this workaraound, what exactly must I select (or 
deselect) on the package selection screen?  And how do I access Xconficurator 
once linux is installed?  I never get a window asking to test my X 
Configuration, so I can't say "No".
Comment 7 Need Real Name 2000-12-19 19:49:56 EST
I've tried installing by deselecting "X Windows System", "GNOME", and "KDE", 
and I get all the way to the post-install configuration.  Then it crashes 
saying "install exited abnormally".
Comment 8 Brent Fox 2000-12-20 16:23:02 EST
So it crashes before you ever get to the video and monitor selection screen? 
This is starting to sound like it may not have anything to do with the video
card.  When it says "install exited abnormally", does it say anything else on
the screen above that?  Also, what does it say on VC#3 (press Alt+F3) and VC#4
(press Alt+F4)?
Comment 9 Need Real Name 2000-12-20 16:59:47 EST
It doesn't say anything above "install exited abnormally", but after that it 
says "--received signal 11".

As for VC#3, I don't think it says anything of consequence.

VC#4 however says the following:

<6>Device not ready.  Make sure disk in drive.
<4> sda: READ Capacity Faiiled
<4> sda: status=1, message=00, host=0 driver=28
<4> sda: extended sense code = 2
<4> sda: block size assumed to be 512 bytes, disk size 1GB
<4> sda:scsidisk I/O error: dev 08:00, sector 0
<4> unable to read partition table

It says this 3 times, then:

<6> Adding swap: 265032K swap-space (priority -1)

I forgot to mention that after it asks what type of installation I'd like to do 
(I always select "Custom"), but before it asks me what program I would like to 
use for partitioning, it says that it failed to mount device "/tmp/sda".  It 
asks to try again or skip and I've been clicking skip.  FYI: I have used 
Powerquest PartitionMagic to create the linux partitions: a 15M boot partition, 
12.6G root partition, and 256M swap space (the latter two are part of the same 
extended partition, and the boot partition is a Primary partition)
Comment 10 Brent Fox 2000-12-20 22:28:40 EST
Ah.  Whole new ball game.  What kind of SCSI controller do you have?  Go to VC#2
and type 'lspci' again and tell me what it says about SCSI controllers.  Also,
how many SCSI drives do you have and is this in a RAID configuration.  If so, is
it hardware or software RAID?
Are you doing the install via CD-ROM, hard drive, NFS, FTP, or HTTP?  If you're
using a CD, is it one you've burned yourself?  
Also, there is the possibility that Partition Magic caused something to get
messed up, although this is unlikely.  When you get to the partitioning screen,
does it list the partitions that are currently on your hard drive?
Comment 11 Need Real Name 2000-12-20 23:04:06 EST
I have a SIIG SCSI controller, but I don't have any hard disks attached to it - 
only a Jaz drive and an Onstream tape drive.

The "lspci" command produced the following results:
00:11.0 SCSI storage controller: Initio Corporation INI-940 (rev 01)

Also, I forgot to mention that I have a Promise Ultra66 controller, so I have 
to pass the following parameters to the kernel at the "boot:" prompt:
ide2=0x18a8,0x189e ide3=0x18a0,0x189a

However, when I attach my hard drive directly to the motherboard, I still get 
the same errors...so I don't think this has anything to do with the problem
(s).  Here is the line from "lspci" regarding the Promise controller:
00:0f.0 Unkown mass storage controller: Promise Technology, Inc. 20262 (rev 01)

I am doing the install via a cd-rom that I burned myself from the 7.0-respin-
disc1.iso file.

Regarding PartitionMagic, I am able to view the partitions with PartitionMagic 
as well as with linux's Disk Druid & Fdisk, so I don't think this is the 
problem either.
Comment 12 Need Real Name 2000-12-20 23:33:30 EST
I tried disconnecting all SCSI devices and now I don't get the error message 
that it can't mount /tmp/sda.  Also, VC#4 doesn't have any of the messages that 
I posted above, but the install still fails when it begins the post-install 
configuration.
Comment 13 Brent Fox 2000-12-21 11:45:05 EST
Are there any error messages on the other VC's when it fails in the post
install?
Comment 14 Need Real Name 2000-12-21 12:38:59 EST
There are no error messages in any of the VCs when it fails at post-install.  
The following came from VC#3, but this happens before the files are installed:

going to insmod raid0.o (path is NULL)
going to insmod raid1.o (path is NULL)
going to insmod raid5.o (path is NULL)
going to insmod fat.o (path is NULL)
going to insmod vfat.o (path is NULL)
going to insmod ext3.o (path is NULL)

Also, from VC#4:

<6> raid0 personality registered
<6> raid1 personality registered
<6> raid5 personality registered
Comment 15 Michael Fulbright 2001-01-11 11:30:49 EST
Have you installed any other OS on this exact hardware?

It sounds like your SCSI hard drive is failing, meaning this is not a software
defect.
Comment 16 Brent Fox 2001-02-09 05:00:13 EST
Closing due to inactivity.  Please reopen if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.