Bug 2237549 - poppler-24.02.0 is available
Summary: poppler-24.02.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-05 22:43 UTC by Upstream Release Monitoring
Modified: 2024-02-08 16:01 UTC (History)
7 users (show)

Fixed In Version: poppler-24.02.0-2.fc40
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-08 16:01:54 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 23.09.0 (#2237549) (980 bytes, patch)
2023-09-05 22:43 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 23.10.0 (#2237549) (980 bytes, patch)
2023-10-02 20:26 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 23.11.0 (#2237549) (980 bytes, patch)
2023-11-01 23:33 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 23.12.0 (#2237549) (980 bytes, patch)
2023-12-01 11:21 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 24.01.0 (#2237549) (980 bytes, patch)
2024-01-02 21:58 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 24.02.0 (#2237549) (1.11 KB, patch)
2024-02-01 23:29 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-09-05 22:43:43 UTC
Releases retrieved: 23.09.0
Upstream release that is considered latest: 23.09.0
Current version/release in rawhide: 23.08.0-1.fc39
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 1 Upstream Release Monitoring 2023-09-05 22:43:49 UTC
Created attachment 1987150 [details]
Update to 23.09.0 (#2237549)

Comment 2 Upstream Release Monitoring 2023-09-05 22:56:36 UTC
the-new-hotness/release-monitoring.org's scratch build of poppler-23.09.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=105800431

Comment 3 Upstream Release Monitoring 2023-10-02 20:26:16 UTC
Releases retrieved: 23.10.0
Upstream release that is considered latest: 23.10.0
Current version/release in rawhide: 23.08.0-1.fc39
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 4 Upstream Release Monitoring 2023-10-02 20:26:21 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-iq0scrs1/poppler.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1696204800
error: Bad file: ./poppler-23.10.0.tar.xz: No such file or directory

RPM build errors:
    Bad file: ./poppler-23.10.0.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 5 Upstream Release Monitoring 2023-10-02 20:26:23 UTC
Created attachment 1991646 [details]
Update to 23.10.0 (#2237549)

Comment 6 Upstream Release Monitoring 2023-11-01 23:32:55 UTC
Releases retrieved: 23.11.0
Upstream release that is considered latest: 23.11.0
Current version/release in rawhide: 23.08.0-1.fc39
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 7 Upstream Release Monitoring 2023-11-01 23:33:01 UTC
Created attachment 1996648 [details]
Update to 23.11.0 (#2237549)

Comment 8 Upstream Release Monitoring 2023-11-01 23:40:18 UTC
the-new-hotness/release-monitoring.org's scratch build of poppler-23.11.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=108441657

Comment 9 Upstream Release Monitoring 2023-12-01 11:21:24 UTC
Releases retrieved: 23.12.0
Upstream release that is considered latest: 23.12.0
Current version/release in rawhide: 23.08.0-1.fc39
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 10 Upstream Release Monitoring 2023-12-01 11:21:29 UTC
Created attachment 2002307 [details]
Update to 23.12.0 (#2237549)

Comment 11 Upstream Release Monitoring 2023-12-01 11:28:35 UTC
the-new-hotness/release-monitoring.org's scratch build of poppler-23.12.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=109766964

Comment 12 Upstream Release Monitoring 2024-01-02 21:58:38 UTC
Releases retrieved: 24.01.0
Upstream release that is considered latest: 24.01.0
Current version/release in rawhide: 23.08.0-1.fc39
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 13 Upstream Release Monitoring 2024-01-02 21:58:42 UTC
Created attachment 2006902 [details]
Update to 24.01.0 (#2237549)

Comment 14 Upstream Release Monitoring 2024-01-02 22:06:10 UTC
the-new-hotness/release-monitoring.org's scratch build of poppler-24.01.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=111210216

Comment 15 Upstream Release Monitoring 2024-02-01 23:28:55 UTC
Releases retrieved: 24.02.0
Upstream release that is considered latest: 24.02.0
Current version/release in rawhide: 23.08.0-3.fc40
URL: http://poppler.freedesktop.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3686/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/poppler

Comment 16 Upstream Release Monitoring 2024-02-01 23:29:00 UTC
Created attachment 2014509 [details]
Update to 24.02.0 (#2237549)

Comment 17 Upstream Release Monitoring 2024-02-01 23:33:30 UTC
the-new-hotness/release-monitoring.org's scratch build of poppler-24.02.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=112767689

Comment 18 Fedora Update System 2024-02-08 14:25:50 UTC
FEDORA-2024-5d0ee4c14d (calligra-3.2.1-29.fc40, gambas3-3.18.4-5.fc40, and 11 more) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-5d0ee4c14d

Comment 19 Fedora Update System 2024-02-08 16:01:54 UTC
FEDORA-2024-5d0ee4c14d (calligra-3.2.1-29.fc40, gambas3-3.18.4-5.fc40, and 11 more) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.