Bug 223759 - Kernel hanged
Kernel hanged
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: fedora-ia64 418441
  Show dependency treegraph
 
Reported: 2007-01-22 03:20 EST by Zhang Yanmin
Modified: 2007-12-18 11:30 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.1-42.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 11:30:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log of kernel kernel-2.6.19-1.2914.fc7.ia64.rpm (15.48 KB, text/plain)
2007-01-29 04:09 EST, Zhang Yanmin
no flags Details
New log of kernel 2.6.20-1.2922 panic (6.75 KB, text/plain)
2007-02-12 04:03 EST, Zhang Yanmin
no flags Details

  None (edit)
Description Zhang Yanmin 2007-01-22 03:20:29 EST
Description of problem:
I used rpm to install the latest kernel and it hanged when rebooting.
The output:
Kernel panic - not syncing: No init found. Try passing init=option to kernel

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2912.fc7.ia64.rpm

How reproducible:
Everytime

Steps to Reproduce:
1. Use yum to upadte mkinitrd on my FC6 ia64 machine.
2. Run #rpm -ivh kernel-2.6.19-1.2912.fc7.ia64.rpm
3. Reboot
  
Actual results:
Hanged.

Expected results:
Kernel boots well.

Additional info:
1) I checked initrd.img and found there is an init script.
Comment 1 Prarit Bhargava 2007-01-22 11:35:12 EST
Yanmin, could you attach the console log so I can see where the hang was?

Or does the system not boot the kernel at all?

P.
Comment 2 Zhang Yanmin 2007-01-22 22:37:06 EST
Prarit,

The system could boot kenel, but kernel couldn't find /init. So it looks like an
initrd issue. I did an initial check of initrd.img and didn't find anything
abnormal.


I tried to capture log by serial port, but it didn't work. Below is something I
copied from the console.

Yanmin

*********************log********************
Net:Registered protocol
Freeing unused kernel memory:1888kb freed
Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init=option to kernel

Comment 3 Zhang Yanmin 2007-01-29 04:08:09 EST
I tried kernel-2.6.19-1.2914.fc7.ia64.rpm. Kernel hanged on one of my
machine(Montecito+Fusion SCSI disk). Pls. see the attached log.
Comment 4 Zhang Yanmin 2007-01-29 04:09:51 EST
Created attachment 146812 [details]
Boot log of kernel kernel-2.6.19-1.2914.fc7.ia64.rpm
Comment 5 Zhang Yanmin 2007-02-12 04:03:39 EST
Created attachment 147878 [details]
New log of kernel 2.6.20-1.2922 panic

I rebuilt kernel 2.6.20-1.2922 with patch of ata/ata_piix to convert GSI to
irq.

Then, rebuilt a new DVD image. kernel panic on my tige-4 Montecito machine.

With the same vmlinuz/initrd, my Madison machine and Hitachi machine don't
panic.

My Hitachi machine is also Montecito. processor info:
arch	   : IA-64
family	   : 32
model	   : 0
model name : Intel(r) Itanium(r) 2 Processor 1.6GHz with 24M L3 Cache for
533MHz Platforms
revision   : 5
archrev    : 0


Tiger-4 Montecito machine processor info:
arch	   : IA-64
family	   : 32
model	   : 0
revision   : 4
archrev    : 0
Comment 6 Zhang Yanmin 2007-02-12 04:10:28 EST
Another difference between my Hitachi and tiger-4 is I disable multi-thread on
hitachi and enable it on tiger-4, because hitachi booting becomes very slow if I
turn on multi-thread.
Comment 7 Dave Jones 2007-05-15 16:25:41 EDT
is this reproducable with f7test4 ?
There were a large number of mkinitrd fixes just before its release which may
have helped.
Comment 8 Zhang Yanmin 2007-05-16 22:38:46 EDT
Dave,

Sorry. I'm very busy in other tasks and have no time to check it.

Yanmin
Comment 9 Doug Chapman 2007-12-18 11:30:21 EST
This has been verified to be resolved on the F8 kernel.

Note You need to log in before you can comment on or make changes to this bug.