Bug 2237971 - python-lsp-server-1.8.0 is available
Summary: python-lsp-server-1.8.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-lsp-server
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-08 06:59 UTC by Upstream Release Monitoring
Modified: 2023-09-22 00:20 UTC (History)
4 users (show)

Fixed In Version: python-lsp-server-1.8.0-1.fc39
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-22 00:20:24 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 1.8.0 (#2237971) (709 bytes, patch)
2023-09-10 06:04 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-09-08 06:59:57 UTC
Releases retrieved: 0.28.3, 0.29.0, 0.29.1, 0.29.2, 0.29.3, 0.30.0, 0.31.0, 0.31.1, 0.31.2, 0.31.3, 0.31.4, 0.31.5, 0.31.6, 0.31.7, 0.31.8, 0.31.9, 0.31.10, 0.32.0, 0.33.0, 0.33.1, 0.33.2, 0.33.3, 0.34.0, 0.34.1, 0.35.0, 0.35.1, 0.36.0, 0.36.1, 0.36.2
Upstream release that is considered latest: 1.7.4
Current version/release in rawhide: 1.4.1-3.fc37
URL: https://pypi.org/project/python-lsp-server

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/191370/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-lsp-server

Comment 1 Upstream Release Monitoring 2023-09-08 07:00:01 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['git', 'commit', '-a', '-m', 'Update to 1.7.4 (#2237971)']' returned non-zero exit status 1.

StdOut:
On branch rawhide
Your branch is up to date with 'origin/rawhide'.

nothing to commit, working tree clean


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 185, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-09-10 06:04:16 UTC
Releases retrieved: 1.8.0
Upstream release that is considered latest: 1.8.0
Current version/release in rawhide: 1.4.1-3.fc37
URL: https://pypi.org/project/python-lsp-server

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/191370/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-lsp-server

Comment 3 Upstream Release Monitoring 2023-09-10 06:04:20 UTC
Created attachment 1987964 [details]
Update to 1.8.0 (#2237971)

Comment 4 Upstream Release Monitoring 2023-09-10 06:08:22 UTC
the-new-hotness/release-monitoring.org's scratch build of python-lsp-server-1.8.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=105982946

Comment 5 Fedora Update System 2023-09-21 10:44:06 UTC
FEDORA-2023-58ed7d993b has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-58ed7d993b

Comment 6 Fedora Update System 2023-09-22 00:20:24 UTC
FEDORA-2023-58ed7d993b has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.