Bug 2238268 - gcc-13.2.1-2.fc40 fails to build due to GDB
Summary: gcc-13.2.1-2.fc40 fails to build due to GDB
Keywords:
Status: CLOSED DUPLICATE of bug 2237392
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: rawhide
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Buettner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-11 06:50 UTC by Jakub Jelinek
Modified: 2023-09-18 13:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-18 13:42:50 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Jakub Jelinek 2023-09-11 06:50:21 UTC
While gcc-13.2.1-2.fc39 built fine on all arches, gcc-13.2.1-2.fc40 built on all arches but i686 and on i686 got stuck twice with GDB crashes at the end, see
https://koji.fedoraproject.org/koji/getfile?taskID=105989286&volume=DEFAULT&name=build.log&offset=-4000
or earlier
https://koji.fedoraproject.org/koji/getfile?taskID=105917507&volume=DEFAULT&name=build.log&offset=-4000
+ /usr/bin/find-debuginfo -j5 --strict-build-id -m -i --build-id-seed 13.2.1-2.fc40 --unique-debug-suffix -13.2.1-2.fc40.i386 --unique-debug-src-base gcc-13.2.1-2.fc40.i386 --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 50000000 -S debugsourcefiles.list /builddir/build/BUILD/gcc-13.2.1-20230906
find-debuginfo: starting
Extracting debug info from 65 files
Fatal glibc error: malloc.c:2594 (sysmalloc): assertion failed: (old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)
Fatal signal: free(): invalid pointer
Fatal signal: Aborted
----- Backtrace -----
0x5679a781 ???
0x568dff7d ???
0xf7f5d59f ???
0xf7f5d589 ???
0xf768f4b6 ???
0xf763af94 ???
0xf762236f ???
0xf7623421 ???
0xf769abcc ???
0xf769cf3a ???
0xf769f5b5 ???
0x56de943b ???
0x568c9c04 ???
0x568ba87f ???
0x568baa2f ???
0x568b59bb ???
0x568baa18 ???
0x568b59bb ???
0x568bb5dc ???
0x568b5a1e ???
0x568b8fbc ???
0x568b59d1 ???
0x568bdcc9 ???
0x568bf363 ???
0x568c02c8 ???
0x56b4b495 ???
0x56b68422 ???
0x56b68743 ???
0x56b15c74 ???
0x56b6330d ???
0x56b67d73 ???
0x56b67e8b ???
0x56b6b06b ???
0x56b6b37b ???
0x56b4d6f4 ???
0x56b5932d ???
0x568e535c ???
0x567d66cb ???
0x56bb106f ???
0x569d6f2a ???
0x569d7021 ???
0x569d94c2 ???
0x569da1bf ???
0x566a0d69 ???
0xf7623d88 ???
0xf7623e4b ???
0x566aa1ba ???
0xffffffff ???
---------------------
A fatal error internal to GDB has been detected, further
debugging is not possible.  GDB will now terminate.
This is a bug, please report it.  For instructions, see:
<https://www.gnu.org/software/gdb/bugs/>.
/usr/bin/gdb-add-index: line 159: 602512 Aborted                 (core dumped) $GDB --batch -nx -iex 'set auto-load no' -iex 'set debuginfod enabled off' -ex "file $file" -ex "save gdb-index $dwarf5 $dir"
gdb-add-index: gdb error generating index for /builddir/build/BUILDROOT/gcc-13.2.1-2.fc40.i386/usr/libexec/gcc/i686-redhat-linux/13/d21
free(): invalid pointer
Fatal signal: Aborted
----- Backtrace -----
0x56780781 ???
0x568c5f7d ???
0xf7f8059f ???
0xf7f80589 ???
0xf768f4b6 ???
0xf763af94 ???
0xf762236f ???
0xf7623421 ???
0xf769abcc ???
0xf769cf3a ???
0xf769f5b5 ???
0x56dcf43b ???
0x5669f264 ???
0x56897dca ???
0x5689bd14 ???
0x568a15dc ???
0x5689ba1e ???
0x5689efbc ???
0x5689b9d1 ???
0x568a3cc9 ???
0x568a5363 ???
0x568a62c8 ???
0x56b31495 ???
0x56b4e422 ???
0x56b4e743 ???
0x56afbc74 ???
0x56b4930d ???
0x56b4dd73 ???
0x56b4de8b ???
0x56b5106b ???
0x56b5137b ???
0x56b336f4 ???
0x56b3f32d ???
0x568cb35c ???
0x567bc6cb ???
0x56b9706f ???
0x569bcf2a ???
0x569bd021 ???
0x569bf4c2 ???
0x569c01bf ???
0x56686d69 ???
0xf7623d88 ???
0xf7623e4b ???
0x566901ba ???
0xffffffff ???
---------------------
A fatal error internal to GDB has been detected, further
debugging is not possible.  GDB will now terminate.
This is a bug, please report it.  For instructions, see:
<https://www.gnu.org/software/gdb/bugs/>.
/usr/bin/gdb-add-index: line 159: 602648 Aborted                 (core dumped) $GDB --batch -nx -iex 'set auto-load no' -iex 'set debuginfod enabled off' -ex "file $file" -ex "save gdb-index $dwarf5 $dir"
gdb-add-index: gdb error generating index for /builddir/build/BUILDROOT/gcc-13.2.1-2.fc40.i386/usr/libexec/gcc/i686-redhat-linux/13/gnat1


Reproducible: Always

Steps to Reproduce:
Rebuild above gcc in mock in f40.

Comment 1 Mark Wielaard 2023-09-11 19:21:04 UTC
Might this be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=2237392 ?

Comment 2 Jakub Jelinek 2023-09-12 09:15:49 UTC
Most likely.

Comment 3 Mark Wielaard 2023-09-18 13:42:50 UTC

*** This bug has been marked as a duplicate of bug 2237392 ***


Note You need to log in before you can comment on or make changes to this bug.