Bug 223839 - NetworkManager fails to save WEP key in keyring, prompts every time
Summary: NetworkManager fails to save WEP key in keyring, prompts every time
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-01-22 18:20 UTC by Will Woods
Modified: 2018-04-11 12:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-18 19:57:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network manager logging info (18.58 KB, text/plain)
2007-01-30 17:37 UTC, Will Woods
no flags Details

Description Will Woods 2007-01-22 18:20:16 UTC
Every time I connect to the wireless network, I'm prompted for my WEP key, and
them prompted for the keyring password to save it. It appears that
NetworkManager is having trouble saving it in the keyring. ~/.xession-errors
contains the following lines:

** (nm-applet:2402): CRITICAL **: nm_gconf_wso_set_key: assertion `key != NULL'
failed

** (nm-applet:2402): WARNING **: <WARN>  nmi_save_network_info(): Error saving
secret for wireless network 'rh-wireless' in keyring: 5

Further info:

[root@zebes ~]# rpm -q NetworkManager
NetworkManager-0.6.5-0.cvs20061025.fc7.1
[root@zebes ~]#  gconftool-2 -R /system/networking
 /system/networking/wireless:
  /system/networking/wireless/networks:
   /system/networking/wireless/networks/rh-wireless:
    bssids = [00:12:80:14:F9:70]
    wep_auth_algorithm = 1
    essid = rh-wireless
    timestamp = 1169072960
    we_cipher = 16

Comment 1 Christopher Aillon 2007-01-29 18:00:18 UTC
Possibly a permissiosn error with the keyring?

rm -r $HOME/.gnome2/keyrings

See if the above helps...

Comment 2 Will Woods 2007-01-29 18:28:26 UTC
Nope. 

I removed the keyrings/ dir and tried to reconnect to the network. It happily
prompted for the key, asked for a password and created default.keyring, then
spat out the same two error messages and continues to prompt for the key
whenever I reconnect.

Comment 3 Matěj Cepl 2007-01-30 01:46:39 UTC
Reporter, do you have by chance two network cards? I wonder if this isn't
DUPLICATE of bug 224022. Chris?

Comment 4 Christopher Aillon 2007-01-30 03:02:57 UTC
I doubt they are related.  Will, can you start with a fresh boot and attach (as
a file) the output of:

sudo grep NetworkManager /var/log/messages 

Comment 5 Will Woods 2007-01-30 17:37:14 UTC
Created attachment 146933 [details]
Network manager logging info

I do have multiple NICs - one wired, one wireless. I suspect this is a pretty
common configuration.

This log is from a freshly-booted, just-reinstalled system. Timeline is as
follows:

11:55 - boot (ipw2200 firmware was installed on system before reboot)
12:07 - connected to wireless network, told networkmanager to save key
12:30 - connected to wired network
12:31 - disconnected from wired network, was prompted for key to connect to
wireless

Comment 6 Will Woods 2007-01-30 17:39:06 UTC
To clarify (now that I've actually read bug 224022): I only have one wireless
NIC, so this isn't related to that bug.

Comment 7 Will Woods 2007-04-18 19:57:08 UTC
Works in current rawhide.


Note You need to log in before you can comment on or make changes to this bug.