Bug 22384 - rat installs the file /etc/sdr/plugins but 'sdr' has /etc/sdr/plugins dir
Summary: rat installs the file /etc/sdr/plugins but 'sdr' has /etc/sdr/plugins dir
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: rat (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-16 13:38 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 15:17:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-12-16 13:38:52 UTC
Rat installs its service description file to /etc/sdr/plugins.  

A look at the Makefile shows it should really install it to plugins/. 
The new sdr package creates /etc/sdr/plugins.

There will be an enermous conflict because rpm tries to turn the dir into a
file..

The following changes to the spec file remedy the problem:

--- rat.spec~	Mon Nov 20 21:36:39 2000
+++ rat.spec	Sat Dec 16 15:30:53 2000
@@ -44,7 +44,7 @@
 %install
 rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT%{_prefix}{/bin,/sbin,/lib,/share/man/man1}
-mkdir -p $RPM_BUILD_ROOT/etc/sdr
+mkdir -p $RPM_BUILD_ROOT/etc/sdr/plugins
 
 (cd rat && %makeinstall )
 
@@ -60,7 +60,7 @@
 %defattr(-,root,root)
 %doc rat/README rat/README.devices rat/README.files rat/README.gsm
 %doc rat/README.mbus rat/README.playout rat/README.timestamps
rat/COPYRIGHT
-/etc/sdr
+/etc/sdr/plugins/*
 %{_prefix}/bin/*
 %{_prefix}/share/man/*/*

Comment 1 Tim Powers 2000-12-18 15:17:02 UTC
Thanks. rat-4.2.10-3 has been built with your suggested fixes applied. It should
show up in rawhide the next time rawhide is updated.

Tim


Note You need to log in before you can comment on or make changes to this bug.