Bug 223862 - line handling issues with text files
line handling issues with text files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: paps (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-22 14:55 EST by Art Werschulz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 06:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The file /etc/cups/lpoptions (404 bytes, text/plain)
2007-01-23 11:23 EST, Art Werschulz
no flags Details

  None (edit)
Description Art Werschulz 2007-01-22 14:55:14 EST
Description of problem:
After an upgrade (FC5->FC6), text files print 70 columns per line, rather than
80.  The printers involved were
HPLJ 4250dtn
HP LJ4000 
Dell 3100cn
HPLJ 4250dtn

Version-Release number of selected component (if applicable):
cups-1.2.7-1.5.fc6

How reproducible:
Every time one uses lpr to print a text file.

Steps to Reproduce:
1. Create a text file, having some lines between 70 and 80 chars long.  In
particular, I tried a test file containing
00000000011111111112222222222333333333344444444445555555555666666666677777777778
12345678901234567890123456789012345678901234567890123456789012345678901234567890

2. Print the file using lpr.
  
Actual results:
The printed output was
0000000001111111111222222222233333333334444444444555555555566666666667
7777777778
1234567890123456789012345678901234567890123456789012345678901234567890
1234567890
There was plenty of room at the end of each line for the missing ten chars.

Expected results:
The printed output should have been
00000000011111111112222222222333333333344444444445555555555666666666677777777778
12345678901234567890123456789012345678901234567890123456789012345678901234567890


Additional info:
Comment 1 Tim Waugh 2007-01-23 05:26:17 EST
What does 'lpoptions -p myprinter' say (with your printer name instead of
'myprinter')?
Comment 2 Art Werschulz 2007-01-23 09:52:39 EST
sobolev@dsm:~$ lpoptions -p ps812
job-sheets=none,none printer-info='HP LJ4000 in LL812'
printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='HP
LaserJet 4000 Series Postscript (recommended)' printer-state=3
printer-state-change-time=1169475807 printer-state-reasons=none
printer-type=37076 cpi=12 lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
sobolev@dsm:~$ lpoptions -p ps812-c
job-sheets=none,none printer-info='Dell 3100cn in LL812 (color)'
printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='Dell
Laser Printer 3100cn Foomatic/ppd (recommended)' printer-state=3
printer-state-change-time=1169495149 printer-state-reasons=none
printer-type=4124 cpi=12 lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
sobolev@dsm:~$ lpoptions -p ps813
job-sheets=none,none printer-info='HPLJ 4250dtn in LL812 (duplex)'
printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='HP
LaserJet 4250 Postscript (recommended)' printer-state=3
printer-state-change-time=1169499727 printer-state-reasons=none
printer-type=168148 cpi=12 lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
sobolev@dsm:~$ lpoptions -p ps813-s
job-sheets=none,none printer-info='HPLJ 4250dtn in LL 813'
printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='HP
LaserJet 4250 Postscript (recommended)' printer-state=3
printer-state-change-time=1169475807 printer-state-reasons=none
printer-type=37076 cpi=12 lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
Comment 3 Tim Waugh 2007-01-23 11:07:33 EST
Do you have an /etc/cups/lpoptions file?  If so, what's in it?

I get the correct results with the defaults (i.e. none of cpi, lpr, page-* set).
Comment 4 Art Werschulz 2007-01-23 11:23:25 EST
Created attachment 146316 [details]
The file /etc/cups/lpoptions
Comment 5 Tim Waugh 2007-01-23 11:44:48 EST
Remove that file, and try again.
Comment 6 Art Werschulz 2007-01-24 10:40:25 EST
I needed to run
# lpoptions -p printerName -o lpi=6
for all the printers, despite the fact that the lp manpage says that the default
value is 6.  Things seem to be okay now.

Thanks!
Comment 7 Tim Waugh 2007-01-24 12:00:54 EST
Hmm, paps should be defaulting to lpi=6 and cpi=10, since that's what texttops does.
Comment 8 Akira TAGOH 2007-03-07 07:20:07 EST
Ok, fixed in 0.6.6-18.fc6
Comment 9 Fedora Update System 2007-03-07 17:57:14 EST
paps-0.6.6-18.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.