Bug 2238843 - Grantlee-editor koji build fails on i686
Summary: Grantlee-editor koji build fails on i686
Keywords:
Status: CLOSED DUPLICATE of bug 2237392
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL: https://kojipkgs.fedoraproject.org//w...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-13 20:03 UTC by marcdeop
Modified: 2023-09-14 10:55 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-14 10:55:03 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description marcdeop 2023-09-13 20:03:46 UTC
I am trying to build grantlee-editor 23.08.0 on Rawhide and the build always fail on i686.

Task with the build: https://koji.fedoraproject.org/koji/taskinfo?taskID=106135776
Log: https://kojipkgs.fedoraproject.org//work/tasks/5776/106135776/build.log

Extract from the log:
+ /usr/bin/find-debuginfo -j5 --strict-build-id -m -i --build-id-seed 23.08.0-1.fc40 --unique-debug-suffix -23.08.0-1.fc40.i386 --unique-debug-src-base grantlee-editor-23.08.0-1.fc40.i386 --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 50000000 -S debugsourcefiles.list /builddir/build/BUILD/grantlee-editor-23.08.0
find-debuginfo: starting
Extracting debug info from 4 files
Fatal glibc error: malloc.c:2594 (sysmalloc): assertion failed: (old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)
Fatal signal: Fatal glibc error: malloc.c:2594 (sysmalloc): assertion failed: (old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)

Reproducible: Always

Steps to Reproduce:
1. Trigger a koji build for grantlee-editor
2. Check i686 build
3.Task never finishes and we see the fatal glibc error


Expected Results:  
Build is successful

Comment 1 Carlos O'Donell 2023-09-14 10:52:32 UTC
This is likely a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=2237392

It's a known issue being worked on by the gdb developers, and has been run into by the gcc builds already.

Comment 2 Carlos O'Donell 2023-09-14 10:55:03 UTC
Given the assertion is identical to that seen with gcc, and it's i686-only on fc40, I'm going to go ahead and mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 2237392 ***


Note You need to log in before you can comment on or make changes to this bug.