Bug 223899 - Requires(post): policycoreutils
Summary: Requires(post): policycoreutils
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 22:46 UTC by Curtis Doty
Modified: 2013-04-30 23:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 14:15:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Curtis Doty 2007-01-22 22:46:09 UTC
Is that really neccessary?

Nevermind the bug in RPM that allows you to erase policycoreutlils without
warning. A quick glance at the specfile makes me think that just fixing the
%post scripts to politely look for restorecon before trying to call it.

And policycoreutils has it's own baggage. Help, save us from dep bloat.

Comment 1 Martin Stransky 2007-01-23 12:51:15 UTC
You can turn off all selinux parts/dependencies by selinux macro. But if we use
selinux we need the restorecon and policycoreutils...

Comment 2 Curtis Doty 2007-01-24 05:11:54 UTC
THat's my point. When one chooses not to use selinux, then bind should not
create arbitrary dependencies. Especially when:

  - the deps are only in %post scripts that can be easily fixed with a simple [
-e /sbin/restorecon ] && /sbin/restorecon yadda
  - there already exists an unfixed bug in rpm that prevents enforcement of this
dep until it's too late

In other words, if they have bind and selinux, then restorecon sure. But why
exactly is restorecon needed for bind without selinux? This is arbitrary and
unneccsary complexity. Especially since policycoreutils drags in even *more*
package deps.

Comment 3 Adam Tkac 2007-02-01 12:12:17 UTC
I think the best fix could be put "[ -e /selinux/enforce ] && [ -x
/sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1
;" into %if %{selinux} %endif statement. If exists bug in rpm it could be fixed
in future and all could works fine. I'm going to fix this problem in rawhide


Note You need to log in before you can comment on or make changes to this bug.