Bug 223904 - Image on web page not showing up
Image on web page not showing up
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
http://www.lancas.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-22 18:17 EST by Rodney Lancaster
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 07:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rodney Lancaster 2007-01-22 18:17:35 EST
Description of problem: Image not showing up in Firefox on FC6 i686 system.


Version-Release number of selected component (if applicable):
uname -a output: Linux solo.lancas.org 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20
14:51:19 EST 2006 i686 i686 i386 GNU/Linux
Firefox version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9)
Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

How reproducible: Very.


Steps to Reproduce:
1.Start firefox
2.Go to web page: http://www.lancas.org/
3.At the bottom of the page just above the "Create Using:" and an image for Open
Office, there is "Hosted by:" and there is supposed to be an image for Hosted by
1&1".  However on FC6 with Firefox 1.5.0.9 it does not show up.  Using firefox
1.5.0.6 it shows up fine.
  
Actual results:
firefox 1.5.0.9 does not show the image.
firefox 2.0 does not show the image.
firefox 1.5.0.9 shows the image fine.

Expected results:
1and1 image should show on all firefox browsers.

Additional info:
Comment 1 Andre Robatino 2007-01-22 19:38:47 EST
  I see the image on a fully updated FC6 i686 box using firefox-1.5.0.9-1.fc6.
Comment 2 Rodney Lancaster 2007-01-22 23:58:58 EST
I just updated using 'yum update' and rebooted. Should be fully updated as well.
Still no 1and1 logo.

uname -a output: Linux solo.lancas.org 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10
19:28:18 EST 2007 i686 i686 i386 GNU/Linux

Firefox: firefox-1.5.0.9-1.fc6

Any other ideas?
Comment 3 Andre Robatino 2007-01-23 00:23:09 EST
  When you say that it does not show the image, do you see an icon for a missing
image, or nothing at all?  Also, I just checked the Google cache for the page
(the page itself is not accessible for me at the moment) and the link for the
image is

http://banner.1and1.com/xml/banner?size=5%26%25number=1

Can you see the image using this link directly?
Comment 4 Rodney Lancaster 2007-01-26 22:38:22 EST
The link shows up fine, directly.  However, the following test page code, using
the recommended link code from 1and1.com does not.

<HTML>
<BODY>
<P ALIGN=CENTER>Hosted by: <A HREF="http://www.1and1.com/?k_id=13749571"
TARGET="_blank">
<IMG SRC="http://banner.1and1.com/xml/banner?size=5%26%25number=1"
NAME="1and1Graphics2" ALT="1and1 Banner" ALIGN=BOTTOM WIDTH=140 HEIGHT=28
BORDER=0></A></P>
</BODY>
</HTML>
Comment 5 Andre Robatino 2007-01-26 22:45:49 EST
  I'm not familiar with HTML, but you should be able to strip out some of this
to create a simplest possible test case, and then fiddle with it to see if you
can find exactly what is causing the image to be hidden.
Comment 6 Rodney Lancaster 2007-01-28 17:35:40 EST
I haven't found the offending item, yet.  

It is interesting to note that this code snippit works fine on firefox 1.5.0.9
on Ubuntu Linux and on Firefox 2.0 on Windows XP.
Comment 7 Rodney Lancaster 2007-01-28 18:30:36 EST
I saved the gif file to my home directory.  Replacing the source with the URL:
file:///home/rlancas/banner.gif worked even with the entire snippet from 1and1.com.

I then took a look at the 3 special characters in the original URL.  The "?",
"&" (%26), and % (%25).  I don't think that is the problem, however, since the
same snippet works fine on firefox 1.5.0.9 on Ubuntu Linux and Firefox on
Windows XP.  I wish I had access to the XML code at 1and1.com to check and seeh
what they are doing to return the gif file.  Anyway, I copied the file
banner.gif to bann?er&%.gif and tried to load it like the URL has specified as
file:///home/rlancas/bann?er%26%25.gif.  It would not load.  When I went and did
a File -> Open and selected the file bann?er&%.gif it came in as
bann%3Fer&%25.gif.  Not an exact test since there is still XML code in between.
 However, based on this short test could the ? somehow be passed incorrectly
from the screen input?

Needless to say, I'm still confused but willing to try other tests if you need
me to.
Comment 8 Matěj Cepl 2007-01-29 12:07:55 EST
Weird, I can reproduce it on RHEL5 with firefox-1.5.0.9-6.el5 and I cannot
reproduce it with epiphany-2.16.0-4.fc6 using the same Gecko library (using
--nodeps and symlink /usr/lib/firefox-1.5.0.7 -> /usr/lib/firefox-1.5.0.9/ ) In
the same time http://banner.1and1.com/xml/banner?size=5%26%25number=1 (URL of
the image) shows just fine in firefox.
Comment 9 Christopher Aillon 2007-01-29 13:03:10 EST
Images go through system libraries, e.g. libpng, libjpeg, etc.  Maybe one of
those is the culprit.
Comment 10 Martin Stransky 2007-09-11 07:57:32 EDT
Works for me (FF2.0&F7).

Note You need to log in before you can comment on or make changes to this bug.