Bug 2239055 - GDM crashes with Xorg enabled
Summary: GDM crashes with Xorg enabled
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 39
Hardware: ppc64le
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-15 02:30 UTC by Trung Lê
Modified: 2023-09-21 11:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-21 11:51:37 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
gdm log (113.13 KB, text/plain)
2023-09-15 02:31 UTC, Trung Lê
no flags Details
partly journal just after Xorg login attempt (283.17 KB, text/plain)
2023-09-20 15:53 UTC, Ronald Warsow
no flags Details

Description Trung Lê 2023-09-15 02:30:53 UTC
Impacted version: 44.1-4.fc39

This issue only occurs in the last update when GDM bumped to 44.1-4

Reproducible: Always

Steps to Reproduce:
1. Edit `/etc/gdm/custom.conf` and set `WaylandEnabled=false`
2. Restart the computer and wait for GDM to start
Actual Results:  
Crashed

Expected Results:  
No crash

This only impacts if Xorg is enabled. Wayland is FINE :D

See the attached log file for stacktrace

Comment 1 Trung Lê 2023-09-15 02:31:26 UTC
Created attachment 1988914 [details]
gdm log

Comment 2 Ronald Warsow 2023-09-20 15:51:59 UTC
same here (after ugrade F38 => F39)

Comment 3 Ronald Warsow 2023-09-20 15:53:55 UTC
Created attachment 1989721 [details]
partly journal just after Xorg login attempt

Comment 4 Ronald Warsow 2023-09-20 19:14:37 UTC
rawhide with updates today is okay (here)

Comment 5 Trung Lê 2023-09-21 11:51:37 UTC
with updates today, the issue is gone.

Comment 6 Ronald Warsow 2023-09-21 11:58:15 UTC
confirming comment #5 !


Note You need to log in before you can comment on or make changes to this bug.