Bug 22393 - gcc 2.96 incorrectly compiles clapack
Summary: gcc 2.96 incorrectly compiles clapack
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-16 20:47 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 22:30:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-16 20:47:48 UTC
When compiled with gcc 2.96 clapack fails its built in tests.
When compiled with 'kgcc' it doesn't fail these tests.

clapack is a numerical library commonly used for high performance
computing. http://www.netlib.org/clapack/

Comment 1 Jakub Jelinek 2000-12-19 16:37:55 UTC
This looks like a bug in clapack, at least it builds and passes tests just
fine if -fno-strict-aliasing is given to gcc, which most probably means
clapack does some invalid type punning somewhere. I haven't analyzed it
yet where is it doing, so I cannot say this for sure.

Comment 2 Jakub Jelinek 2004-10-03 22:30:47 UTC
GCC 2.96-RH is now too old.  If you are able to reproduce similar
problems with contemporary GCC (3.4, 4.0), please reopen.


Note You need to log in before you can comment on or make changes to this bug.