Bug 2239345 - ImageMagick-7.1.1.26 is available
Summary: ImageMagick-7.1.1.26 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-17 19:31 UTC by Upstream Release Monitoring
Modified: 2024-01-24 01:32 UTC (History)
8 users (show)

Fixed In Version: ImageMagick-7.1.1.26-2.fc39 ImageMagick-7.1.1.26-2.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-01-23 00:58:14 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 7.1.1.16 (#2239345) (992 bytes, patch)
2023-09-17 19:31 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.17 (#2239345) (992 bytes, patch)
2023-09-20 07:48 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.18 (#2239345) (992 bytes, patch)
2023-09-23 20:05 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.19 (#2239345) (991 bytes, patch)
2023-10-02 06:54 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.20 (#2239345) (991 bytes, patch)
2023-10-09 06:38 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.21 (#2239345) (992 bytes, patch)
2023-10-22 15:38 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.22 (#2239345) (991 bytes, patch)
2023-12-04 19:44 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.23 (#2239345) (992 bytes, patch)
2023-12-11 07:06 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.24 (#2239345) (992 bytes, patch)
2023-12-25 20:27 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.25 (#2239345) (992 bytes, patch)
2023-12-31 12:12 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 7.1.1.26 (#2239345) (991 bytes, patch)
2024-01-08 20:39 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-09-17 19:31:38 UTC
Releases retrieved: 7.1.1.16
Upstream release that is considered latest: 7.1.1.16
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 1 Upstream Release Monitoring 2023-09-17 19:31:48 UTC
Created attachment 1989252 [details]
Update to 7.1.1.16 (#2239345)

Comment 2 Upstream Release Monitoring 2023-09-17 20:00:01 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.16-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=106319573

Comment 3 Upstream Release Monitoring 2023-09-20 07:48:32 UTC
Releases retrieved: 7.1.1.17
Upstream release that is considered latest: 7.1.1.17
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 4 Upstream Release Monitoring 2023-09-20 07:48:43 UTC
Created attachment 1989656 [details]
Update to 7.1.1.17 (#2239345)

Comment 5 Upstream Release Monitoring 2023-09-20 08:14:40 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.17-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=106421437

Comment 6 Upstream Release Monitoring 2023-09-23 20:05:09 UTC
Releases retrieved: 7.1.1.18
Upstream release that is considered latest: 7.1.1.18
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 7 Upstream Release Monitoring 2023-09-23 20:05:18 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-qih_k2w1/ImageMagick.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1695427200
error: Bad file: ./ImageMagick-7.1.1-18.tar.xz.asc: No such file or directory
error: Bad file: ./ImageMagick-7.1.1-18.tar.xz: No such file or directory

RPM build errors:
    Bad file: ./ImageMagick-7.1.1-18.tar.xz.asc: No such file or directory
    Bad file: ./ImageMagick-7.1.1-18.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 8 Upstream Release Monitoring 2023-09-23 20:05:20 UTC
Created attachment 1990230 [details]
Update to 7.1.1.18 (#2239345)

Comment 9 Upstream Release Monitoring 2023-10-02 06:53:58 UTC
Releases retrieved: 7.1.1.19
Upstream release that is considered latest: 7.1.1.19
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 10 Upstream Release Monitoring 2023-10-02 06:54:07 UTC
Created attachment 1991548 [details]
Update to 7.1.1.19 (#2239345)

Comment 11 Upstream Release Monitoring 2023-10-02 07:21:51 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.19-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=106978457

Comment 12 Upstream Release Monitoring 2023-10-09 06:38:09 UTC
Releases retrieved: 7.1.1.20
Upstream release that is considered latest: 7.1.1.20
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 13 Upstream Release Monitoring 2023-10-09 06:38:29 UTC
Created attachment 1993040 [details]
Update to 7.1.1.20 (#2239345)

Comment 14 Upstream Release Monitoring 2023-10-09 07:06:48 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.20-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=107257187

Comment 15 Upstream Release Monitoring 2023-10-22 15:37:56 UTC
Releases retrieved: 7.1.1.21
Upstream release that is considered latest: 7.1.1.21
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 16 Upstream Release Monitoring 2023-10-22 15:38:07 UTC
Created attachment 1995087 [details]
Update to 7.1.1.21 (#2239345)

Comment 17 Upstream Release Monitoring 2023-10-22 16:09:35 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.21-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=107934795

Comment 18 Upstream Release Monitoring 2023-12-04 19:43:52 UTC
Releases retrieved: 7.1.1.22
Upstream release that is considered latest: 7.1.1.22
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 19 Upstream Release Monitoring 2023-12-04 19:44:04 UTC
Created attachment 2002783 [details]
Update to 7.1.1.22 (#2239345)

Comment 20 Upstream Release Monitoring 2023-12-04 20:09:44 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.22-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=109911443

Comment 21 Upstream Release Monitoring 2023-12-11 07:05:46 UTC
Releases retrieved: 7.1.1.23
Upstream release that is considered latest: 7.1.1.23
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 22 Upstream Release Monitoring 2023-12-11 07:06:07 UTC
Created attachment 2003698 [details]
Update to 7.1.1.23 (#2239345)

Comment 23 Upstream Release Monitoring 2023-12-11 07:35:27 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.23-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=110171130

Comment 24 Upstream Release Monitoring 2023-12-25 20:27:39 UTC
Releases retrieved: 7.1.1.24
Upstream release that is considered latest: 7.1.1.24
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 25 Upstream Release Monitoring 2023-12-25 20:27:48 UTC
Created attachment 2005883 [details]
Update to 7.1.1.24 (#2239345)

Comment 26 Upstream Release Monitoring 2023-12-25 20:51:00 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.24-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=110842334

Comment 27 Upstream Release Monitoring 2023-12-31 12:12:05 UTC
Releases retrieved: 7.1.1.25
Upstream release that is considered latest: 7.1.1.25
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 28 Upstream Release Monitoring 2023-12-31 12:12:15 UTC
Created attachment 2006684 [details]
Update to 7.1.1.25 (#2239345)

Comment 29 Upstream Release Monitoring 2023-12-31 12:35:35 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.25-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=111099039

Comment 30 Remi Collet 2024-01-08 10:22:32 UTC
Please skip 7.1.1-26 and 6.9.13-4 which are broken

See:
IM6: https://github.com/ImageMagick/ImageMagick6/pull/303
IM7: https://github.com/ImageMagick/ImageMagick/pull/7013

Comment 31 Upstream Release Monitoring 2024-01-08 20:39:26 UTC
Releases retrieved: 7.1.1.26
Upstream release that is considered latest: 7.1.1.26
Current version/release in rawhide: 7.1.1.15-1.fc40
URL: https://imagemagick.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/328484/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/ImageMagick

Comment 32 Upstream Release Monitoring 2024-01-08 20:39:35 UTC
Created attachment 2007841 [details]
Update to 7.1.1.26 (#2239345)

Comment 33 Upstream Release Monitoring 2024-01-08 21:10:30 UTC
the-new-hotness/release-monitoring.org's scratch build of ImageMagick-7.1.1.26-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=111492224

Comment 34 Sergio Basto 2024-01-08 21:46:35 UTC
(In reply to Remi Collet from comment #30)
> Please skip 7.1.1-26 and 6.9.13-4 which are broken
> 
> See:
> IM6: https://github.com/ImageMagick/ImageMagick6/pull/303
> IM7: https://github.com/ImageMagick/ImageMagick/pull/7013

thanks for the info, btw I'm thinking add packit automatisms to this package.

Comment 35 Fedora Update System 2024-01-15 15:31:52 UTC
FEDORA-2024-32ce2217e7 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2024-32ce2217e7

Comment 36 Fedora Update System 2024-01-15 15:32:16 UTC
FEDORA-2024-b695f01221 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2024-b695f01221

Comment 37 Fedora Update System 2024-01-16 01:06:55 UTC
FEDORA-2024-d23b0f5e76 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-d23b0f5e76`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-d23b0f5e76

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 38 Fedora Update System 2024-01-16 01:19:16 UTC
FEDORA-2024-6f8c1d9005 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-6f8c1d9005`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-6f8c1d9005

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 39 Fedora Update System 2024-01-23 00:58:14 UTC
FEDORA-2024-6f8c1d9005 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 40 Fedora Update System 2024-01-24 01:32:59 UTC
FEDORA-2024-d23b0f5e76 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.