Bug 224 - Tmpwatch doesn't clean some man pages
Tmpwatch doesn't clean some man pages
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-28 20:17 EST by Marc MERLIN
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-07 05:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1998-11-28 20:17:38 EST
Forward of an old unfixed bug report to bugzilla

There are two problems with the tmpwatch cron
job

1) I doesn't go through all the catman
directories
2) I doesn't remove formatted man pages created by
root

For #1, the command line is missing a few
directories
As for #2, a preformatted man page will be saved like
this:

l
/var/catman/cat1/ls.1.gz
-r--rw-r--   1 root     man          5056 jui 27 04:36
ls.1.gz

tmpwatch by default doesn't erase files that are not
writable by root

The tmpwatch cron job should look like
this:
/usr/sbin/tmpwatch 240 /tmp
/var/tmp
/usr/sbin/tmpwatch -f 240
/var/catman/{X11R6/cat?,cat?,local/cat?}

(The reason for splitting the line in two is that for
security reasons, we avoid to run tmpwatch -f on /tmp)

Not that I really hope that you're going to change this, but
it'd be really nice to run tmpwatch on /tmp only, not
/var/tmp where sysadmins tend to store stuff and very few
applications write to anyway. I believe this is what
Slowlaris does
Comment 1 Preston Brown 1999-02-10 16:47:59 EST
fixed in rawhide.
Comment 2 Marc MERLIN 1999-05-04 02:07:59 EDT
This was fixed in RH 5.9 but RH 6.0 switched back to having just:
/usr/sbin/tmpwatch 240 /tmp /var/tmp /var/catman/cat?

Is this intentional?
Comment 3 Jeff Johnson 1999-06-07 05:47:59 EDT
No just a screwup. I've fixed this again in our repository, and
build tmpwatch-1.7-2.

Note You need to log in before you can comment on or make changes to this bug.